1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Old blog post throwing error...

Old blog post throwing error...

4 posts, 0 answered
  1. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    19 Sep 2009
    Link to this post

    Anyone have any idea why some of my oldest blog post all of a sudden throw this error: I just upgraded to SP1, this is all i can think of....


    Duncan

    Server Error in '/' Application.

    Invalid content ID specified

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: Invalid content ID specified

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ArgumentException: Invalid content ID specified]
       Telerik.Cms.Engine.WebControls.ContentView.CreateSingleContent() +2965
       Telerik.Cms.Engine.WebControls.ContentView.CreateChildControls() +4649
       Telerik.Blogs.WebControls.BlogPosts.CreateChildControls() +21
       System.Web.UI.Control.EnsureChildControls() +87
       System.Web.UI.Control.PreRenderRecursiveInternal() +44
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +842
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    20 Sep 2009
    Link to this post
    Hi Duncan Evans,

    The error is thrown because the content ID is null. You can check [sf_CmsContentBase] and see whether you have the same content item as the broken one.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Duncan Evans
    Duncan Evans avatar
    122 posts
    Registered:
    07 Jul 2009
    20 Sep 2009
    Link to this post
    I am able to see the blog item in the admin pages (even edit and save it) but the error is thrown when accessing the blog items page on the public side. Even deleting the blog item and then recreating it produces the same error. Only the first 2 blog items, its pretty weird...

    Duncan
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    21 Sep 2009
    Link to this post
    Hi Duncan Evans,

    In the method from where the Argument exception comes from we get the current IContent item from a list of items by using its ID. In your case the content is always null. Try to patch the project again. It is possible that the database was not correctly updated. You can also check the SchemaVersion in [sf_CmsVariables] table. If the problem persists send us the porject's database and we will look into the matter.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
4 posts, 0 answered