1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / sflb.ashx requests are not being cached by browser

sflb.ashx requests are not being cached by browser

8 posts, 0 answered
  1. bjnoffsi
    bjnoffsi avatar
    6 posts
    Registered:
    13 Sep 2009
    19 Nov 2009
    Link to this post
    I'm probably just missing something but is there any way to assure that assets served by the ContentHttpHandler are cached by the end-user's browser? When analyzing the requests on a page refresh, all files ending with sflb.ashx are returning a 200 status code rather than a 304. Thanks.
  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    20 Nov 2009
    Link to this post
    Hi,

    Please take a look at the Library options in which the image resides in - there is an option for caching the images by the browser. Screenshot attached. 

    Let us know if you have any other questions. 

    Kind regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. bjnoffsi
    bjnoffsi avatar
    6 posts
    Registered:
    13 Sep 2009
    21 Nov 2009
    Link to this post
    Thanks Georgi. We have "" checked. Is there something else we need to enable? I've attached a screenshot. Thanks.
  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    23 Nov 2009
    Link to this post
    Hello,

    After extensive testing today, we found an issue with this option. It is now fixed though, and we will have a service pack very soon. In some cases the image was still loaded from the cache, but the Status code was wrong.
    We have updated your Telerik account for noticing this, and once again, the fix will be available with the next service pack.

    Greetings,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. bjnoffsi
    bjnoffsi avatar
    6 posts
    Registered:
    13 Sep 2009
    24 Nov 2009
    Link to this post
    Hi, Thanks for finding the bug. When do you anticipate having a fix available? Thanks!
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    25 Nov 2009
    Link to this post
    Hello bjnoffsi,

    The fix will be available in next SP release. The Sitefinity 3.7 SP2 release will be available next week.

    Regards,
    Radoslav Georgiev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. warfee
    warfee avatar
    27 posts
    Registered:
    10 Aug 2007
    30 Nov 2009
    Link to this post
    How would you use a web service to access images in a Sitefinity Library?
  8. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    30 Nov 2009
    Link to this post
    Hi warfee,

    You can take a look at a sample web service accessing content items from Sitefinity here - Use the Content Manager API in a Web Service. You should also take a look at the Library Manager API - Managing Files with LibraryManager - to gain a better look on how to work with items from Sitefinity Libraries in your web.service.

    Regards,
    Radoslav Georgiev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
8 posts, 0 answered