+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / SiteFinity + Custom Module

SiteFinity + Custom Module

7 posts, 0 answered
  1. Andrew Hyslop
    Andrew Hyslop avatar
    21 posts
    Registered:
    23 Jun 2010
    24 Aug 2010
    Link to this post
    Hey guys / gals,

    Just another newbie post regarding SiteFinity :)

    I am attempting to write a custom module (pluggable) and am following along with the instructions in SitefinityDeveloperManual_Aricles_v3_7.chm.  I have downloaded and installed the Visual Studio template (Sitefinity_Pluggable_Module.zip) for use in Visual Studio 2010 and have followed the instructions provided in the "Instructions.txt" file that is opened automatically.  I am receiving these error:

    Error   102   The type or namespace name 'GenericContainer' could not be found (are you missing a using directive or an assembly reference?)   d:\UserFiles\*********\My Documents\Visual Studio 2010\Projects\*****.Video\WebControls\PublicControl.cs   87   48   *****.Video
    Error   103   The type or namespace name 'GenericContainer' could not be found (are you missing a using directive or an assembly reference?)   d:\UserFiles\*********\My Documents\Visual Studio 2010\Projects\*****.Video\WebControls\Admin\ControlPanel.cs   103   47   *****.Video
    Error   104   The type or namespace name 'GenericContainer' could not be found (are you missing a using directive or an assembly reference?)   d:\UserFiles\*********\My Documents\Visual Studio 2010\Projects\*****.Video\WebControls\Admin\CommandPanel.cs   104   47   *****.Video

    I have added the required references, but it seems one has been missed.  Any ideas?

    Cheers!
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    24 Aug 2010
    Link to this post
    Hello Andrew Hyslop,

    VS templates are provided in an old sample. Please refer the the new modules  valid for 3.6 and 3.7 editions



    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Andrew Hyslop
    Andrew Hyslop avatar
    21 posts
    Registered:
    23 Jun 2010
    25 Aug 2010
    Link to this post
    I have followed the "Sample pluggable module: Contacts pluggable module" example to the letter and am having horrendous problems.

    I get 90+ build errors, so I will only list a few of them:

    Error   105   The type or namespace name 'Telerik' could not be found (are you missing a using directive or an assembly reference?)   D:\UserFiles\*********\Desktop\SiteFinity Module Example\Sample.Contacts\WebControls\Admin\ContactsCommandPanel.cs   4   7   Sample.Contacts
    Error   131   The type or namespace name 'ApplicationPermission' could not be found (are you missing a using directive or an assembly reference?)   D:\UserFiles\*********\Desktop\SiteFinity Module Example\Sample.Contacts\Security\GlobalPermission.cs   10   37   Sample.Contacts
    Error   146   'Sample.Contacts.WebSysTemplate' is not an attribute class   D:\UserFiles\*********\Desktop\SiteFinity Module Example\Sample.Contacts\WebControls\Admin\ContactsItemNew.cs   17   10   Sample.Contacts
    Error   208   Could not load referenced assembly "D:\UserFiles\*********\Desktop\SiteFinity Module Example\Sample.Contacts\bin\Debug\Sample.Contacts.dll".  Caught a FileNotFoundException saying "Could not load file or assembly 'D:\UserFiles\*********\Desktop\SiteFinity Module Example\Sample.Contacts\bin\Debug\Sample.Contacts.dll' or one of its dependencies. The system cannot find the file specified.".   D:\UserFiles\*********\Desktop\SiteFinity Module Example\Sample.Contacts.Data\ResGen   Sample.Contacts.Data
    Error   213   Exception of type 'System.Web.HttpParseException' was thrown.   Sitefinity/Admin/Services/ContactsService.asmx   

    I am using Visual Studio 2010 so when I "Add An Exisitng Project" to the website it converts it.  Also, since I have opened an existing SiteFinity installation that is not local to my system, should the referenced assembly be pointing to my local file system?  Sorry for the newbie questions, but this is a battle to get a working example of a pluggable module.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Aug 2010
    Link to this post
    Hi Andrew Hyslop,

    Please add reference to the needed assemblies. These are general ASP.NET errors

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Andrew Hyslop
    Andrew Hyslop avatar
    21 posts
    Registered:
    23 Jun 2010
    25 Aug 2010
    Link to this post
    So do this (substitute the appropriate Project name for this example):

    "Expand the References folder in the Telerik.Samples.Products and fix reference problems if any (this can happen if your website is using a different version of Sitefinity than the one I used to create a sample)"

    This was taken from the instructions from another example you have provided.
  6. Andrew Hyslop
    Andrew Hyslop avatar
    21 posts
    Registered:
    23 Jun 2010
    25 Aug 2010
    Link to this post
    That seems to have fixed the reference problems, thanks!

    One last issue, I am getting the following error:

    Error   110   Exception of type 'System.Web.HttpParseException' was thrown.   A:\www.********.com\Sitefinity\Admin\Services\ContactsService.asmx   1   

    Any idea's on this one?
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Aug 2010
    Link to this post
    Hi Andrew Hyslop,

    It looks  like the web service cannot be properly loaded. Could you check whether something has not blocked it or you have not altered the asmx file. The problem could appear if you have any chars in the url that are not or cannot be properly encoded.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
7 posts, 0 answered