+1-888-365-2779
Try Now
More in this section

Forums / Developing with Sitefinity / Working with Images in the Content Editors

Working with Images in the Content Editors

4 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    11 Mar 2009
    Link to this post
    Are there guidelines for working with images in the content editors?  In my page I see the images fine, but when I go into edit mode, all the images are broken...I uploaded a couple to the Images\Documents section, but I don't seem to be able to reference those in the Image Manager.  The Image manager actually has nothing in it at all...

    Example:
    Here's my snippet (which works on the page, but not in edit mode)
        <snippet name="PDF Download Link">
          <![CDATA[
                        <a href="documents/File.pdf">New Download Link<img alt=" PDF " height="16" width="16" src="../images/pagePDFIcon.gif" /></a>
                    ]]>
        </snippet>


  2. Ricky
    Ricky avatar
    12 posts
    Registered:
    24 Sep 2012
    13 Mar 2009
    Link to this post
    Hello Steve,

    Can you show us the acutal code from the ascx file? May be there is something there that  generates this snippet . 
    Suggestions:
    If you use Page.ResolveClient url , it will not work in design mode. You can try with full absolute path.

    Thanks,
    Mehfuz


    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. marco pessina
    marco pessina avatar
    16 posts
    Registered:
    02 Nov 2009
    16 Sep 2010
    Link to this post
    Hi,
    I've a problem related to this topic.
    When I use a snippet like this to add a little download image near a link:
    <snippet name="insert download link">
        <![CDATA[
             <img style="border:none;" alt="Download" src="/project/Libraries/grafics/download_icon.sflb.ashx" />
        ]]>
    </snippet>

    Or another similar to add a preformatted link with icon:
    <snippet name="insert link and icon">
        <![CDATA[
                <a href="#" target="_blank"> Right clic,Properties... to edit link text and url </a><img style="border:none;" alt="Download" src="/project/Libraries/grafics/download_icon.sflb.ashx" />
            ]]>
    </snippet>

    So, when I use it, all the text into the paragraph is substituted with the code snippet. There's a special sintax to avoid it and preserve the original text?

    Thanks.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    17 Sep 2010
    Link to this post
    Hello marco pessina,

    I am not able to reproduce this issue using similar snippet to this one you have posted

    <snippet name="insert download link" /><img style="border: medium none;" alt="Download" src="/EmptyProject/Libraries/test111/AddRecord.sflb.ashx" />



    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered