+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / 404 Error in Admin Section (Pages)

404 Error in Admin Section (Pages)

8 posts, 2 answered
  1. Matthew Calhoun
    Matthew Calhoun avatar
    4 posts
    Registered:
    12 Nov 2009
    04 Dec 2010
    Link to this post
    I just did a clean install of 4.0.962.0 on a clean build of Win 2008.

    Created an IIS website with it's own application pool. Home dir is D:\Sites\MySite\
    Set the application pool to .NET 4
    Set the pool to run as a specific user
    Made sure app pool user has full control to D:\Sites\MySite
    Website uses host headers for www.mysite.com and mysite.com.

    Create a new project using Project Manager
    Click Browse
    Go to IIS
    Select www.mysite.com
    Provide name of cms and path of D:\Sites\MySite\cms
    Status Online

    Browse to new site and setup database on SQL Server with Windows Authentication

    Browse to Admin site, login
    Click Pages
    Create New Page
    Click "Create and go to add content"

    I get a popup "IIS 7.0 Detailed Error - 404.6"

    Help!

    Thanks,
    Matt

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 Dec 2010
    Link to this post
    Hello Matthew,

    It looks like the problem is related to the defined verbs in your IIS. Please take a look at Error message when you visit a Web site that is hosted on IIS 7.0: "HTTP Error 404.6 – VERB_DENIED"

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  3. Matthew Calhoun
    Matthew Calhoun avatar
    4 posts
    Registered:
    12 Nov 2009
    05 Dec 2010
    Link to this post
    Hi Ivan,

    That definitely seems to be the issue. The strange part, however, is that my original configuration was set to:

    <verbs allowUnlisted="false" applyToWebDAV="true">
        <add verb="GET" allowed="true" />
        <add verb="HEAD" allowed="true" />
        <add verb="POST" allowed="true" />
        <add verb="OPTIONS" allowed="true" />
    </verbs>
    and only upon changing to:

    <verbs allowUnlisted="true" applyToWebDAV="true"/>

    Which to me suggests that another verb rather than GET or POST is being used? Do you have any thoughts on this?

    Thanks,
    Matt
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 Dec 2010
    Link to this post
    Hi Matthew,

    WebDAVModule should not be used. It has to be removed.

    <remove name="WebDAVModule" />

    The same applies for the handler.

    <handlers>
          <remove name="WebDAV" />

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Matthew Calhoun
    Matthew Calhoun avatar
    4 posts
    Registered:
    12 Nov 2009
    05 Dec 2010
    Link to this post
    Hi Ivan,

    I am not using WebDAV and it IS disabled as you said. I think you're missing my question...

    Now I have:
    <verbs allowUnlisted="false">
        <add verb="GET" allowed="true" />
        <add verb="HEAD" allowed="true" />
        <add verb="POST" allowed="true" />
        <add verb="OPTIONS" allowed="true" />
    </verbs>

    and I get the error, but if I change to :

    <verbs allowUnlisted="true" />

    it works. This suggests to me that some other verb is being used...just trying to figure out what. I would rather specify the required verbs than to just allow everything.

    Thanks,
    Matt
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 Dec 2010
    Link to this post
    Hello Matthew,

    We require GET,HEAD, PUT, POST.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  7. Matthew Calhoun
    Matthew Calhoun avatar
    4 posts
    Registered:
    12 Nov 2009
    05 Dec 2010
    Link to this post
    Thanks Ivan!

    I can confirm that by changing to:

    <verbs allowUnlisted="false">
        <add verb="GET" allowed="true" />
        <add verb="HEAD" allowed="true" />
        <add verb="POST" allowed="true" />
        <add verb="OPTIONS" allowed="true" />
        <add verb="PUT" allowed="true" />
    </verbs>
    everything works as expected!

    Take care,
    Matt
  8. Ryan Eaves
    Ryan Eaves avatar
    1 posts
    Registered:
    10 Mar 2006
    12 Mar 2014
    Link to this post

    I found this post while trying to resolve an error in SF 6.0 with content items getting locked and not being able to unlock them. I discovered that the verb DELETE also needs to be added. This article explains how to do it through IIS if you have request filtering turned on:

    http://www.iis.net/configreference/system.webserver/security/requestfiltering/verbs

     Hope that helps somebody!

    The IIS error I was getting was a 404.6.

     

8 posts, 2 answered