Try Now
More in this section

Forums / General Discussions / Browser Support

Browser Support

3 posts, 0 answered
  1. Jared
    Jared avatar
    122 posts
    04 Apr 2013
    28 Mar 2014
    Link to this post

    I found the following in the System Requirements.

    Internet Explorer 8, 9, 10
    Firefox 3.6+
    Silverlight 4 plug-in is recommended for best user experience
    Chrome 8+

    My question is, does this browser support relate to the front-end or back-end of Sitefinity or both?

  2. Mike
    Mike avatar
    10 posts
    19 Feb 2014
    24 May 2014 in reply to Jared
    Link to this post
    I'm am trying to find the answer to the same question.  Seeing JS errors in the CMS in IE8, personally.
  3. Vassil Vassilev
     Vassil Vassilev avatar
    308 posts
    21 Jan 2015
    28 May 2014
    Link to this post

    The system requirements are for both.

    For example if the current Telerik.Web.UI version used by Sitefinity support Chrome 8+ and due to the fact that those controls are used on both frontend and backend this forces Sitefinity to support Chrome 8+.

    Vassil Vassilev
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
3 posts, 0 answered