+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Custom 404

Custom 404

6 posts, 0 answered
  1. Victor
    Victor avatar
    94 posts
    Registered:
    15 Jun 2011
    20 Mar 2013
    Link to this post
    Anyone else unable to get custom 404 to work, when you are a logged in backend user after upgrading to 5.4?

    If I browse a page that doesn't exist, I get the custom 404.  If I log into the backend and then browse the same page, I get the default IIS 404 page.

    Confirmed the behavior in Fiddler, the only difference in the request are the cookies.  Once request generates a 302 redirect to the custom page, the one where I'm logged in, generates a 404 response

    Is this by design?
  2. Arno
    Arno avatar
    249 posts
    Registered:
    08 Sep 2010
    21 Mar 2013 in reply to Victor
    Link to this post
    Hi Victor,

    Well, if I do what you described it works fine for me. My site has also been upgraded to 5.4 and it has a custom 404 page. I hope Support can help you out!
  3. Victor
    Victor avatar
    94 posts
    Registered:
    15 Jun 2011
    21 Mar 2013 in reply to Arno
    Link to this post
    Is your site on IIS6 or 7?
  4. Arno
    Arno avatar
    249 posts
    Registered:
    08 Sep 2010
    21 Mar 2013 in reply to Victor
    Link to this post
    I'm running the site locally on Windows 7 and IIS 7.5.
  5. Victor
    Victor avatar
    94 posts
    Registered:
    15 Jun 2011
    21 Mar 2013 in reply to Arno
    Link to this post
    Yeah, it works for me locally on 7 also.  I should have clarified that the issue is on IIS, and its not just specific to one sites.  It's across 2-3 sites that I tested
  6. Victor Velev
    Victor Velev avatar
    1345 posts
    Registered:
    06 Jul 2015
    25 Mar 2013
    Link to this post
    Hello Victor,

    We have a bug logged recently when it comes to IIS6 and custom errors on Sitefinity 5.4:

    http://www.telerik.com/support/pits.aspx#/public/sitefinity/14522


    What I would suggest you ( if you use IIS 6 and encounter the problem ) would be to switch to IIS 7+, until the problem is fixed. If you are not using IIS6, let us know.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
6 posts, 0 answered