Try Now
More in this section

Forums / General Discussions / Error when Accessing Pages Section

Error when Accessing Pages Section

7 posts, 0 answered
  1. Courtney
    Courtney avatar
    9 posts
    30 Mar 2005
    18 Aug 2010
    Link to this post
    I'm encountering an error when accessing the pages section immediately after a project startup. The page basically loads nothing and an alert window pops up with the message "The collection already contains an address with scheme http.&nbsp;There can be at most one address per scheme in this collection. <br>Parameter name: item". I'm thinking the error is Silverlight in nature, but I'm not sure. I've deployed the site in IIS7 on Windows Server 2008 SP2. See the attached image for more info.

    Has anyone else experienced this issue before? Couldn't find anything in this forum.
  2. inanc
    inanc avatar
    5 posts
    11 Mar 2009
    19 Aug 2010
    Link to this post
    Yes I am experiencing the same .
  3. Richard Baugh
    Richard Baugh avatar
    201 posts
    22 Aug 2012
    19 Aug 2010
    Link to this post
    I was getting the same error when I had multiple bindings on my site. It has to do with WCF.

    I have found two options for fixing this:
    1)    Remove all but one binding for the site
    2)    Specify the base url the site is to use for WCF in the web.config

                <add prefix="http://www.thebaseaddresswcfshouldlistento.com"/>

    Here is just one of the articles that talks about this:
  4. Courtney
    Courtney avatar
    9 posts
    30 Mar 2005
    19 Aug 2010
    Link to this post


    Yeah, you're definitely right about it being a WCF issue. And it's an error that's not just on the pages section, but on every page of the admin section. I just tried your suggestions, even though I had only one binding (I added a base address prefix) and there still seems to be some issue. I'm thinking there has to be some configuration issue on IIS or in the web.config I'm missing. I'll post more if I find out what's going on. Below is the error in detail straight from the server's event viewer.

     Exception: System.ServiceModel.ServiceActivationException: The service '/Sitefinity/Services/Pages/PagesService.svc' cannot be activated due to an exception during compilation.  The exception message is: Index was out of range. Must be non-negative and less than the size of the collection. 
    Parameter name: index. ---> System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection. 
    Parameter name: index 
       at System.ThrowHelper.ThrowArgumentOutOfRangeException() 
       at System.Collections.Generic.List`1.get_Item(Int32 index) 
       at System.Collections.ObjectModel.ReadOnlyCollection`1.get_Item(Int32 index) 
       at System.ServiceModel.Web.WebServiceHost.AddAutomaticWebHttpBindingEndpoints(ServiceHost host, IDictionary`2 implementedContracts, String multipleContractsErrorMessage) 
       at System.ServiceModel.Web.WebServiceHost.OnOpening() 
       at Telerik.Sitefinity.Utilities.MS.ServiceModel.Web.WebServiceHost2.OnOpening() 
       at Telerik.Sitefinity.Web.Services.DefaultServiceHost.OnOpening() 
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath) 
       at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) 
       --- End of inner exception stack trace --- 
       at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result) 
       at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) 
  5. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    01 Feb 2016
    20 Aug 2010
    Link to this post
    Hi all,

    Richard, you are correct about the multiple bindings. I have just reproduced the issue. It reproduces if you have multiple http bindings. If you have http and https only the error does not reproduce. Thank you for sharing your solutions to the problem and I think that this should make it into our developer's guide.

    Richie, could you please share a little bit more about your configuration, I am still trying to reproduce the second issue?

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Courtney
    Courtney avatar
    9 posts
    30 Mar 2005
    20 Aug 2010
    Link to this post

    Well it would seem I've figured out the issue. It was an internal network issue; our firewall wasn't letting the external IP map to the local one I had set in IIS. Once that was fixed, everything started working fine. Which makes sense, considering the errors I was receiving were WCF in nature. So lesson learned: gotta make sure all the IP addresses and DNS entries map to the correct server before setting up a Sitefinity project in IIS.

    It's good to know about the multiple http bindings issue; I'm sure I would have run into that issue sooner or later.

    Thanks for the help,

  7. peter shitote
    peter shitote avatar
    5 posts
    17 Mar 2010
    19 Sep 2010
    Link to this post

    I have been working days on end trying to figure out how to configure my sitefinity 4 beta to work with IIS7. Finally, I got a solution, which I believe most of you who are developing in sitefinity would be interested in. If you are getting an error accessing the "Page" link in sitefinity web app, perhaps Windows is denying you permission to access some resources through IIS. Check the application pool you are using and make sure it is defaultapplication pool (remember to configure defaultapplication pool to run on Network Service). Then navigate to the physical file location (location in your hard disk) where you installed sitefinity website. Right click the folder then under "Security tab" click Edit > Add. Type "Network Service" in the text box shown at the bottom of the dialog. Click Ok. Now give "Full Control" permission to this user. You can also give full control to "Local Service" in place of network service depending on the user SQL Server is running on.

    Peter Shitote

7 posts, 0 answered