+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / "FrontpageRPCException: Could not retrieve the server extension version" when creating a NEW 5.0 project on Windows Server 2008 R2?

"FrontpageRPCException: Could not retrieve the server extension version" when creating a NEW 5.0 project on Windows Server 2008 R2?

3 posts, 0 answered
  1. SVA Webmaster
    SVA Webmaster avatar
    85 posts
    Registered:
    18 Jul 2007
    06 Mar 2012
    Link to this post
    I have installed SF 5.0 on a Win2008R2 server with IIS installed. I have other 4.3 and 4.4 sites set up and running fine on this server, however when I try to create a new SF 5.0 site using the Project Wizard and "http://" path location I get the error "FrontpageRPCException: Could not retrieve the server extension version." (See screenshots)
  2. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    09 Mar 2012
    Link to this post
    Hi Craig,

     This is probably a problem with the remote server not supporting FrontPageExtensions. Can you try creating the project locally and then deploy it on your server, rather than creating it directly on the server? This is usually the recommended process - create/develop/implement the project locally and then deploy it on the server, rather than directly creating it on the production server.

    Regards,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Arno
    Arno avatar
    249 posts
    Registered:
    08 Sep 2010
    29 Oct 2012
    Link to this post
    For future readers stumbling upon this post: I had this error creating a new 5.2 project. This is what solved it for me:

    1. Close the Project Manager.
    2. I had a commented out project in C:\Program Files (x86)\Telerik\Sitefinity 5.2\Projects.xml and removed it.
    3. Start the Project Manager and try again.
3 posts, 0 answered