+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / HTTP request was forbidden with client authentication scheme 'Anonymous' when trying to save page

HTTP request was forbidden with client authentication scheme 'Anonymous' when trying to save page

10 posts, 0 answered
  1. Jeff
    Jeff avatar
    118 posts
    Registered:
    08 Jul 2011
    04 Feb 2013
    Link to this post

    I edited a page in my CMS and when I tried to save I received the following message:

    The HTTP request was forbidden with client authentication scheme 'Anonymous'.

    Anyone know how to resolve this? Appears to be an authentication issue with one of the WCF web services but I don't know how to fix it.

    Happens on any page I edit and try to save.

    I'm running SF 5.1.
  2. Jeff
    Jeff avatar
    118 posts
    Registered:
    08 Jul 2011
    06 Feb 2013
    Link to this post
    Could really use some help on this.
  3. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    08 Dec 2016
    07 Feb 2013
    Link to this post
    Hello,

    Check if in IIS settings for the site you have enabled the option for AnonymousAuthentcation and all other authentication optiosn are disabled. This depends on the authentication your site is using, by default the authentication is Claims Authentication (the authentication type can be checked in Administration->Settings->User Authentication), here is the documentation for the IIS setup:

    Perform one of the following:
    • If you are using Forms authentication, make sure Anonymous Authentication and Forms Authentication are enabled and all other authentications are disabled.
    • If you are using Claims-based authentication, make sure only Anonymous Authentication is enabled and all other authentications are disabled.

    If you are running sitefintiy on IIS 6 follow the steps in our guide, you should not be experiencing any problems, as we have tested Sitefinity with such settings and is working as expected. In addition to our instructions can you verify that you have configured IIS as described in the blog post as well:

    http://www.sitefinity.com/blogs/joshmorales/posts/josh-morales-blog/2011/02/23/installing_sitefinity_4_on_iis_6


    Can you make sure that all handler mappings are correctly set as per the above blog post, as we have encountered similar issues in the past with other users, who did not set the mappings for the services correctly.

    The following article can also be useful:

    http://stackoverflow.com/questions/2299736/wcf-deployment-to-iis-6-results-in-403-permission-error



    Kind regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  4. Kevin
    Kevin avatar
    16 posts
    Registered:
    09 Feb 2012
    26 Mar 2013 in reply to Jeff
    Link to this post
    I just finished struggling with this exact same error for the better part of two days. In my case, it was on a test server that was IP restricted to my workstation's outgoing IP via the IP Address and Domain Restrictions feature in IIS.

    Turns out that when you try to Publish, Save, Delete, or probably several other workflow-type of operations, at least one request is made to the site FROM ITS OWN IP. Check your server logs, and you'll see something like this after a Publish attempt:

    2013-03-26 18:55:32 [site's IP] POST /DefaultWorkflows/PagesApprovalWorkflow.xamlx - 80 - [site's IP] - 403 6 5 0

    Note I've manually replaced the actual IP with [site's IP] for privacy reasons.

    So, the solution is to add the site's own IP address to the list of allowed IPs. As soon as I did this, bam, everything worked again.
  5. Elsane
    Elsane avatar
    30 posts
    Registered:
    06 Jan 2012
    23 Apr 2013 in reply to Kevin
    Link to this post
    Hello,

    I'm encountering the same problem on a website running SF5.1

    I'm getting the "The HTTP request was forbidden with client authentication scheme 'Anonymous'" message on any page or blog articles I try to edit or create.

    This website is up since 3 months and was running properly until yesterday.

    We've setup a test website on the same machine and the same IIS configuration which works perfectly.

    Do you have other ideas of the cause ?

    thanks

    Elsa
  6. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    08 Dec 2016
    26 Apr 2013
    Link to this post
    Hello,

    If the site have been working if you know the what what the latest changes to the server settings have been it will be best in narrowing down the cause of the problem.
    I think the most common cause is the IIS setting
    • If you are using Forms authentication, make sure Anonymous Authentication and Forms Authentication are enabled and all other authentications are disabled.
    • If you are using Claims-based authentication, make sure only Anonymous Authentication is enabled and all other authentications are disabled.
    If the authentication type for the project have been changes from Administration->Settings->User Authentication this is a possible culprit for the problem.

    All the best,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Michael
    Michael avatar
    67 posts
    Registered:
    16 Mar 2012
    16 Sep 2013 in reply to Kevin
    Link to this post
    Thank you Kevin. You pointed me in the right direction to fix a broken firewall rule on our side that resulted in this error.
  8. Kevin
    Kevin avatar
    16 posts
    Registered:
    09 Feb 2012
    19 Sep 2013 in reply to Michael
    Link to this post
    Glad I could help someone else with this issue. Revisiting the thread reminds me of how frustrating it was.

    Kevin
  9. Mansoor
    Mansoor avatar
    52 posts
    Registered:
    29 Jul 2013
    03 Dec 2014
    Link to this post

    Hi,

    when i try to publish my news i got the  error

    "The HTTP request was forbidden with client authentication scheme 'Anonymous' "
    my server details are 

    Server: Windows server 2008 R2  and  IIS :version 6.1

    our website is " Forms authentication" ,in IIS i have enabled Anonymous Authentication and Forms Authentication and all other authentications are disabled. still i am getting same issue.

    Can one one guide us what could be the problem.

    thank you

    mak

  10. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    05 Dec 2014
    Link to this post
    Hello all,

    @Mansoor

    I have replied to this issue in the support ticket. I am posting the response from there:

    "Reasons for the occurance of this exception as well as troubleshooting suggestions have been discussed in detail in this forum thread. Please go through it and try the solutions suggested there.

    Additionally, there are scenarios where your FireWall may be blocking the requests so I can recommend you turn it off and see if the behavior reproduces. Also try turning off the IIS IP Address and Domain Restrictions if there are any.
    "



    Regards,
    Ivan D. Dimitrov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
10 posts, 0 answered