+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Legacy Dashboard vs. Dynamic Dashboard

Legacy Dashboard vs. Dynamic Dashboard

12 posts, 0 answered
  1. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    20 May 2015
    Link to this post

    From what I have read the Dashboard page change quite a bit starting with version 6.2.

    http://www.sitefinity.com/developer-network/forums/general-discussions-/sitefinity-6-2-released

    I recently updated our site as a proof of concept to version 8.0.  the dashboard page is listed as "Legacy Dashboard".  How do we get the new Dynamic Dashboard?​

     

  2. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    25 May 2015
    Link to this post
    Hi Jared,

    Please, go to the backend pages section from Administration -> Backend Pages. Expand the Dashboard group page under the Sitefinity group page. Check the child pages, you should have the Dashboard and Legacy Dashboard pages. To set the Dashboard page as default, reorder the pages, so the Dashboard one is first under the group page. I have attached an image for reference.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  3. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    29 May 2015 in reply to Nikola Zagorchev
    Link to this post

    I am getting the following message on the new dashboard page:

    Server Error in '/' Application.
    Cannot find template "~/AnalyticsModule/Telerik.Sitefinity.Analytics.Server.Infrastructure.Web.UI.AnalyticsTimeline.Designer.AnalyticsTimelineDashboardDesigner.ascx".
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: Cannot find template "~/AnalyticsModule/Telerik.Sitefinity.Analytics.Server.Infrastructure.Web.UI.AnalyticsTimeline.Designer.AnalyticsTimelineDashboardDesigner.ascx".

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    Stack Trace:

    [ArgumentException: Cannot find template "~/AnalyticsModule/Telerik.Sitefinity.Analytics.Server.Infrastructure.Web.UI.AnalyticsTimeline.Designer.AnalyticsTimelineDashboardDesigner.ascx".] Telerik.Sitefinity.Web.UI.ControlUtilities.GetTemplate(String virtualPath, String resourceFileName, Type assemblyInfo, String templateDeclaration, Boolean addChildrenAsDirectDescendants) +537 Telerik.Sitefinity.Web.UI.ControlUtilities.GetControlTemplate(TemplateInfo info) +992 Telerik.Sitefinity.Web.UI.SimpleView.get_LayoutTemplate() +179 Telerik.Sitefinity.Web.UI.SimpleView.get_Container() +40 Telerik.Sitefinity.Web.UI.SimpleView.CreateChildControls() +68 System.Web.UI.Control.EnsureChildControls() +189 System.Web.UI.Control.PreRenderRecursiveInternal() +60 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Control.PreRenderRecursiveInternal() +222 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4297

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18056             

    I know a work around would be to go into the page itself and delete that widget, but I would like to know why I am getting this error in the first place.
  4. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    01 Jun 2015 in reply to Jared
    Link to this post
    Any explanation or update to the error about the Analytics Timeline Dashboard?
  5. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    03 Jun 2015
    Link to this post
    Hi Jared,

    Could you please check whether the version of the Telerik.Sitefinity.Analytics is the correct one, you can also replace it with the one from the _EmptyProject? The template that is embedded resource could not be found and the control could not be initialized. Another option will be to try restart the Dashboard and Analytics modules by setting their records in the SystemConfig the following way:
    <add name="Analytics" />
    <add name="Dashboard" />
    Hope this helps.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  6. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    03 Jun 2015 in reply to Nikola Zagorchev
    Link to this post

    You mentioned to check the version of Telerik.Sitefinity.Analytics is the correct one.  Where do we check this?  You also mentioned to replace it with the one from _EmptyProject.  I do not see it in _EmptyProject.  The only thing I see related to Analytics is  Telerik.Sitefinity.Analytics.Server.Infrastructure.

     

    I did set the records in the SystemConfig as you stated and that did not get rid of the error.  I looked at the services listed under Modules & Services and both the Analytics and Dashboard are "Active" with no reporting errors.

    Also, I did attempt to Deactivate and re-Activate via the backend and that also did not get rid of the error.

  7. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    03 Jun 2015 in reply to Nikola Zagorchev
    Link to this post

    I did find a fix for this at the following link, it it 5th comment in post by Herbert.

    http://www.sitefinity.com/developer-network/forums/bugs-issues-/missing-dashboard-widgets​

  8. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    04 Jun 2015
    Link to this post
    Hello Jared,

    I am glad you have managed to resolve the issue. The module has not upgraded successfully, since the virtual path has not been added:
    <add resourceLocation="Telerik.Sitefinity.Analytics.Server.Infrastructure" resolverName="EmbeddedResourceResolver" virtualPath="~/AnalyticsModule/*" />

    This way the embedded resources from that location cannot be loaded and the controls that reference them will indeed throw the experienced exception.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  9. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    04 Jun 2015 in reply to Nikola Zagorchev
    Link to this post
    Is this a known bug with the upgrade?  what is the root cause of the module not being upgraded successfully?  What can be done prior to the upgrade to resolve this issue without manually having to add this line in the config file?  
  10. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    08 Jun 2015
    Link to this post
    Hi Jared,

    Have you modified the virtual path config manually or registered additional virtual paths in your application? Has anything been logged in the UpgradeTrace log? Are your configurations stored in the database? This is not a common issue and we have not been able to identify why it could happen during the upgrade.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  11. Jared
    Jared avatar
    122 posts
    Registered:
    04 Apr 2013
    08 Jun 2015 in reply to Nikola Zagorchev
    Link to this post

    I have not got anything Failed in Upgrade Log related to this.

    Configurations are stored in the DB.

    Here is what is in our file within the solution upon adding the resource location stated above to resolve this issue:
    <?xml version="1.0" encoding="utf-8"?>
    <virtualPathSettingsConfig xmlns:config="urn:telerik:sitefinity:configuration" xmlns:type="urn:telerik:sitefinity:configuration:type" config:version="5.4.4040.0">
    <virtualPaths>
    <add resourceLocation="Telerik.Sitefinity.Ecommerce" resolverName="EmbeddedResourceResolver" virtualPath="~/SFEcommerce/*" />
    <add resourceLocation="Telerik.Sitefinity.Forums" resolverName="EmbeddedResourceResolver" virtualPath="~/SFForums/*" />
    <add resourceLocation="Masthead" resolverName="EmbeddedResourceResolver" virtualPath="~/Masthead/*" />
    <add resourceLocation="Allison.Internet.Sitefinty.Widgets" resolverName="EmbeddedResourceResolver" virtualPath="~/AllisonInternetSitefintyWidgets/*" />
    </virtualPaths>
    </virtualPathSettingsConfig>

    I can get the value of the config file that is stored in the DB as well if needed.  Since I have a fix for this in place, I do not think it is a huge deal.  I was just checking to see if this was a common issue or a known bug in the upgrade.  With the link to another post posted in previous post, I do know I am not the only one who has experienced this.

     

  12. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    11 Jun 2015
    Link to this post
    Hi Jared,

    We have had few cases before, but we have not been able to identify the source of the problem. They have been mainly for upgrade from older versions ~5.0. The virtual path config has not been upgraded probably during the upgrade of the analytics module, but we have not been able to reproduce it clearly or get more information on the matter.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
12 posts, 0 answered