+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / New user/role cannot see pages tab in backend

New user/role cannot see pages tab in backend

3 posts, 0 answered
  1. Richard
    Richard avatar
    63 posts
    Registered:
    20 Jan 2010
    30 Jan 2014
    Link to this post
    Hi,

    We have a client running Sitefinity 5.4.4010.0 that has just created a new user/role. The role has permissions set for the various content items and the role has been given permission to a page/pages.

    When the new user logs in they can see the content menu item but there isn't a link for pages. The only way for the new user to see the pages is if they are added to an existing role such as administrators.

    Has anyone come across this before and is there a work around/fix?

    Just to add the new user is also in the backend users role.

    Thanks
    Richard
  2. Sabrie Nedzhip
    Sabrie Nedzhip avatar
    534 posts
    Registered:
    05 Dec 2016
    03 Feb 2014
    Link to this post
    Hi Richard,

    First, can you please go to Administration -> Roles, click on the Permissions link of your custom role and make sure that the role is granted permissions for Pages under the Widget templates section.

    Then please go to the Pages tab, click on the Permissions for all pages link in the right side of the page and give your custom role create/edit/modify/delete permissions for the Pages (please, see the screenshot). Here is a video for your convenience that demonstrates the steps above.

    You can also refer to the following articles for additional information on this subject:

    1. How to grant access to Pages tab
    2. Setting permissions
    3. Managing roles

    Regards,
    Sabrie Nedzhip
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
  3. Richard
    Richard avatar
    63 posts
    Registered:
    20 Jan 2010
    03 Feb 2014 in reply to Sabrie Nedzhip
    Link to this post
    Hi Sabrie,

    That's very helpful and now works as expected. 

    Thanks
    Richard
3 posts, 0 answered