1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / RadTree on RC 4.0 crashes project

RadTree on RC 4.0 crashes project

3 posts, 0 answered
  1. Jon
    Jon avatar
    41 posts
    Registered:
    20 Oct 2010
    29 Nov 2010
    Link to this post
    Hi,

             When I go to "Edit in Visual Studio" from the project screen and drop a RadTree control onto a User Control and compile I can no longer access my project. I get the error message below when trying to access my project. There is no code for the RadTree. This happens by simply once again, dropping it onto a User Control. The error message is below. Is there any way to fix this ? Thanks in advance.
    jon

    ERROR MESSAGE :

    Server Error in '/TestProject2' Application.


    Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.929.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.929.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Telerik.Web.UI, Version=2010.2.929.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' could not be loaded.

     

    WRN: Assembly binding logging is turned OFF.

    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

    Note: There is some performance penalty associated with assembly bind failure logging.

    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


    Stack Trace:

     

    [FileLoadException: Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.929.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)]

       Telerik.Sitefinity.Abstractions.ObjectFactory.RegisterIoCTypes() +0

       Telerik.Sitefinity.Abstractions.Bootstrapper.Bootstrap() +92

       Telerik.Sitefinity.Web.SitefinityHttpModule.Init(HttpApplication context) +29

       System.Web.HttpApplication.InitModulesCommon() +192

       System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +1504

       System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +348

       System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +200

       System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +286

     


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1


  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    16 Jun 2017
    29 Nov 2010
    Link to this post
    Hello Jon,

    Please verify that your project has a reference to Telerik.Web.UI, Version=2010.2.929.40. It looks like that there is a missing reference to Telerik.Web.UI, Version=2010.2.929.40 or this assembly is not located in the destination you have used to make the reference - Bin folder or GAC.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Jon
    Jon avatar
    41 posts
    Registered:
    20 Oct 2010
    29 Nov 2010
    Link to this post
    Thanks !

       I fixed it. I dragged a Tree view to a User Control instead of just referencing the assembly in the project.
3 posts, 0 answered