1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Right to left alignment

Right to left alignment

28 posts, 1 answered
  1. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    20 Jul 2011
    Link to this post
    I havecreated a website using Sitefininity 4.1.Here i am using two languages English and Arabic.I have attached the two design layouts.my question is ,Does Sitefinity provide any facility to change left to right layout into right to left on my language selection.
  2. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    20 Jul 2011
    Link to this post
    Hello Rakesh,

    Automatically switching to rtl direction on selecting Arabic language is a tough one, though - you can create two separate themes for your site in two theme folders in the App_Themes directory of your project. You can find more information on how to create and register a backend theme on this section of our Designer's Guide. One of the themes will be used by your English pages. When you create an English page you will select the page to use that theme. In the second theme you will style your CSS so that the text direction is right to left, and you will set your Arabic pages to use this theme.
    Another option is to  hook to the index changed event of the language dropdown list in the administration - it is a standard Asp.Net control, and check which is the selected item's value. Then you can include a CSS style dynamically, based on that value.
    You can also switch, let's say two CSS files depending on the language selected. This might happen in the Page_Load event.

    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    21 Jul 2011
    Link to this post
    hai Boyan Barnev ,

    Thanks for your support.I will follow the link and update you 
  4. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    21 Jul 2011
    Link to this post
    I followed the link and created a theme and it registerd.But when I go to ' CreateTemplate ' and selected the theme I got an error 


    "Theme 'QSTPEnglish' cannot be found in the application or global theme directories."


    What will be the mistake that I have been done..?
    can you please help me.

    please find the attachment to see my App_Themes structure...

    Thanks in advance....




  5. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    21 Jul 2011
    Link to this post
    Hi Rakesh,

    Most likely this is due to either incorrect relative path specified (please check if there's not a typo in the registration configuration) or the identity you are using does not have rights to read the contents of that folder. Can you please try moving the theme in a folder structure similar to this one:
    /App_Data/Sitefinty/WebsiteTemplates/YourTemplate/App_Themes/YourTheme
    and register it as per the documentation. Actually we have a complete tutorial on how to create a theme for Sitefinity from scratch, you can follow the steps described here. If the problems persist, please do not hesitate to get back to me, and if possible, please provide me with temporary login credentials for the site's backend so I can inspect the settings myself. Thanks in advance.

    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    21 Jul 2011
    Link to this post
    Hi Boyan Barnev ,

    Thanks thanks Thanks a lot.
    As per the tutorial things are fine and working farely.
    Now I want to use my own master page as the template.I will work on this tomorrow and will get back to you if any problem..

    Thanks once again Boyan.....
  7. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    25 Jul 2011
    Link to this post
    Hi Boyan Barnev ,

    Still I am in trouble with master pages.As per the tutorial the theme is applied to a template while it is created.
    But here I created a master page like image that attached.The leftmenu and the content below the bread crump are usercontrols that should be dragged.Here how can I use the theme and change the theme as per my language selection ?

    can you please help me?

    Thanks in advance..
  8. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    25 Jul 2011
    Link to this post
    Hi Rakesh,

    Actually my idea was to either load different CSS styles for your masterpage, depending on the current culture, or simply have two themes registered and when editing the pages that are in the language translation which requires rtl you can assign the theme to them. You can set the theme that's loaded in Design->Page Templates, when you open a template for editing you have the option to specify which theme is applied to that template. Basically you can have two identical theme, just the one which is rtl should contain CSS specifying the direction property, for example:
    body 
            font-family: Georgia; 
            color: black
            font-size: 12px
            background: white
            direction: rtl
    }


    Best wishes,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    25 Jul 2011
    Link to this post
    Hi Boyan Barnev,
    Thanks for your fast reply.I created two themes and solved that.
    Now I want to add new language Arabic and I got the link
    http://www.sitefinity.com/blogs/grishakaranikolov/posts/11-04-13/localizing_the_administrative_backend_of_sitefinity.aspx.

    But when I click on " Languages " nothing happens.All other four menus are working except languages.
    Is their any file missing...
    can you help me?

    Thanks

  10. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    25 Jul 2011
    Link to this post
    Hi Rakesh,

    Can you please try browsing the site in Firefox and use developer tools like FireBug to inspect whether an exception is thrown when you're accessing the Languages menu, and if yes, please paste it here so we can advise you further.

    Best wishes,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    25 Jul 2011
    Link to this post
    hi ,

    I checked it using firebug.Their is no error,but the anchor tag for " Languages " does not contains "href".

    <ul class="sfBasicSettingsList">
        <li>
            <a id="ctl04_ctl00_ctl00_ctl02_ctl00_ctl00_generalLink" class="sfSel" href="/SfThemes/Sitefinity/Administration/Settings/Basic/">General</a>
        </li>
    
        <li>
            <a id="ctl04_ctl00_ctl00_ctl02_ctl00_ctl00_languagesLink">Languages</a>
        </li>
        <li>
            <a id="ctl04_ctl00_ctl00_ctl02_ctl00_ctl00_commentsLink" href="/SfThemes/Sitefinity/Administration/Settings/Basic/Comments/">Comments</a>
        </li>
        <li>
            <a id="ctl04_ctl00_ctl00_ctl02_ctl00_ctl00_twitterLink" href="/SfThemes/Sitefinity/Administration/Settings/Basic/Twitter/">Twitter</a>
    
        </li>
        <li>
            <a id="ctl04_ctl00_ctl00_ctl02_ctl00_ctl00_newslettersLink"></a>
        </li>
    </ul>
    
    
    how can I solve this...
  12. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    25 Jul 2011
    Link to this post
    Hi Rakesh,

    If there's no hyperlink for that text, then you have either deleted the Languages backend page, or your license does not support multilingual feature. Please take a look at our License comparison table to check if this is not the case.

    Best wishes,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
  13. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    25 Jul 2011
    Link to this post
    Thanks Boyan.

    I am using  "Community" version which does not support multiple languages.

    Thanks once again.
  14. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    25 Jul 2011
    Link to this post
    Hi Boyan ,

    I updated my license to Enterprise and done all the steps in the tutorial and set Arabic as my default language.
    But the language is not changed after refreshing.Then go to Administration -> Settings and got an error

    Specified time is not supported in this calendar. It should be between 04/30/1900 00:00:00 (Gregorian date) and 05/13/2029 23:59:59 (Gregorian date), inclusive.
    Parameter name: time "

    Is their any file missing....please find the attachment


  15. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    26 Jul 2011
    Link to this post
    Hi Boyan ,

    Did I miss any language file that cause the above  mentioned error...
    can you please  help me ...?
  16. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    26 Jul 2011
    Link to this post
    Hi Rakesh,

    Can you please try if the issue reproduces on a newly created project, using the same version of Sitefinity project manager? The error indicates that somewhere in the system you have entered invalid time, can you please describe in detail the exact steps you have taken (e.g. configuration changes, language culture applied, any customizations to the project itself) before this error appeared so we can try to reproduce it locally. In the meantime to revert the changes you can go to your Sitefinity project's folder and navigate to App_Data/Sitefinity/Configuration/ResourcesConfig.config file and remove the localization settings related to the second language. Save the changes and restart the application, and this should revert the changes you have made.

    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  17. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    26 Jul 2011
    Link to this post
    Hi,

    As you said I created a new project and what I did is described below 

    • I created the project
    • Then Administration  > Settings

    In General Settings the time zone is “ (GMT+05:30) Chennai, Kolkata, Mumbai, New Delhi ”                                                       and the Checkbox is unchecked.

    • Then Languages > Manage backend languages >Add Languages

    Selected  “ Arabic ”

    • Then “Set as default”  and “Save Changes”
    • Administration > Interface Labels & Messages
    • Import Language Pack >Select Xlsx file and “ Import “
    • After that I refreshed the page but no change .So I logout and logged in once again.
    • Then Administration  > Settings gives me the error.
  18. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    26 Jul 2011
    Link to this post
    Hi Rakesh,

    Please take a look at the sample video I've recorded for you, following the steps you have mentioned, and let me know if I have missed something, as the functionality is working fine on my new project using build version 4.1.1501.0 Sitefinity 4.1 SP2

    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  19. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    26 Jul 2011
    Link to this post
    Hello Rakesh,

    I'm sorry forgot to attach the video, please find it attached to this reply.

    Best wishes,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  20. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    29 Jul 2011
    Link to this post
    Hello Boyan Barne,

    OK, I don't know how to solve my issue..I watched the video..
    Really I am fed up because I was struggling with this issue  for the last two weeks.Could you please let me know where can I find the latest build version of Sitefinity 4.1

    This issue persists only in  Arabic.I tried Spanish language but their is no problem.Is their  any way to find the cause of this issue ?is it related with our time zone?

    (The video will be more useful if you included the steps to add Arabic)

    Thank you so much
  21. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    29 Jul 2011
    Link to this post
    Hi Rakesh,

    I'm sorry to hear that you're still experiencing error with this issue. Please find the latest officially supported Sitefinity version for download on your client account here and test this functionality with a blank project using that version. If the problems persist, please do not hesitate to let us know, so maybe we can arrange you sending over the project so we can inspect it locally. Thanks in advance.

    All the best,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  22. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    29 Jul 2011
    Link to this post
    Hi Boyan,

    Thanks a lot for your great support
  23. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    29 Jul 2011
    Link to this post
    Hi Boyan,

    I tried it with the latest build.Still the same problem.In the Arabic version all other links except the " Settings " are working without any problem." Settings " is the one that brings me error.

    What else I am missing ?
    Is their anything other than this tutorial.I am following this tutorial
    http://www.sitefinity.com/blogs/grishakaranikolov/posts/11-04-13/localizing_the_administrative_backend_of_sitefinity.aspx
    can you help me?Is it mt problem ?
  24. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    29 Jul 2011
    Link to this post
    Hi Boyan,

    Please take a look at this 
    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/3-x-pre-release-forums-retired/big-error.aspx

    Here, as a fix , a procedure is given to update the database.Is their any thing like this for back end localization ?
  25. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    29 Jul 2011
    Link to this post
    Hello Boyan,
    I got your mail.What should I do?
    you have given me some login credential but for what?
  26. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    29 Jul 2011
    Link to this post
    Hello Rakesh,

    Please find attached a blank project created using our latest officially supported version Sitefinity 4.1. SP3, which has Arabic set as the default backend language, has the Arabic language pack uploaded and the timezone is set as per your requirements. The project is running fine on our side, please attach the database located in App_Data folder to your SQL Server instance, modify the DataConfig.config file to point to the right DB location and run the project. I hope there won't be any problems experienced with it, however if anything turns out, please let us know.

    P.S. The archive password and the login credentials for the project have been submitted on your email, please find them there.

    Regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  27. Rakesh
    Rakesh avatar
    72 posts
    Registered:
    11 Jan 2011
    29 Jul 2011
    Link to this post
    Hello Boyan,

    I don't know what to say.
    The problem is still their in the version that you have given me.I think it is some thing related to my local machine.
    I just downloaded Sitefinity4.1 from the link you have given,installed it and created a project.That is the only Telerik component in my system.Is their any thing required else ?

    I think I have to drop the project if the error persists more..
  28. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    16 Aug 2017
    29 Jul 2011
    Link to this post
    Hello Rakesh,

    I surely wouldn't give up that easily :) If the project that I sent you exhibits the same behavior as the ones you have described in your previous replies, it looks like this is not a Sitefinity-related problem, but rather an infrastructure/configurations issue. Are you running the project from Visual Studio integrated server / Sitefinity project manager or from IIS? Also, can you please make sure you have everything configured as per our Installation and Administration Guide? Lookign forwards to your reply.

    Regards,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
28 posts, 1 answered