+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Sequence contains no elements

Sequence contains no elements

6 posts, 0 answered
  1. Nathan
    Nathan avatar
    9 posts
    Registered:
    04 Mar 2011
    05 May 2011
    Link to this post
    Now that I fixed our other major issue, I'm back to where I was yesterday.  I submitted a ticket for this, but haven't got a response back yet.

    I am getting a "Sequence contains no elements" error when I try to edit our home page.  Another issue that came out of nowhere..  I've looked at our page template and everything looks fine there, so it must be a control on the page itself.  Any ideas?  

    I've attached the stack trace to this post.
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    24 Mar 2017
    11 May 2011
    Link to this post
    Hi Nathan,

    Most probably, some of your ContentBlock controls have no IDs (the ID property is deleted). That breaks Page Editor. This issue will be fixed in the next internal build. As a workaround, you could  try to run the following script

    You can also run the following code to see if there are some issues with the control IDs

    var manager = PageManager.GetManager();
    var controlType = typeof(ContentBlock).FullName;
    var propName = "ID";     
     
    var controls = manager.GetControls<PageControl>().Where(pc => pc.ObjectType == controlType);
    foreach(var cb incontrols)
    {
        var idProp = cb.Properties.FirstOrDefault(p => p.Name == propName);
        if(idProp == null)
        {
            // the id prop for this control is null
        }
    }
     
    var draftControls = manager.GetControls<PageDraftControl>().Where(pdc => pdc.ObjectType == controlType);
    foreach(var cb indraftControls)
    {
        var idProp = cb.Properties.FirstOrDefault(p => p.Name == propName);
        if(idProp == null)
        {
          // the id  prop for this controlis null
        }
    }
     




    Work with database backup.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Utkarsh
    Utkarsh avatar
    0 posts
    Registered:
    14 Oct 2016
    10 Jan
    Link to this post

    Hi,

    I am new to Sitefinity and am trying to create a demo application for basic understanding using a Sitefinity 9.2 Trial Version.

    After creating a new project in Sitefinity CMS Project Manager, when I am trying to Install Sitefinity Thunder Module in that application using Visual Studio, I get 'Sequence contains no elements' error message, and in the background, the installation process goes on endlessly.

    I could be missing some vital piece of the puzzle. Please help in getting this resolved, as so far I haven't been able to move forward on my demo application work.

    Thanks,

    Utkarsh

  4. Utkarsh
    Utkarsh avatar
    0 posts
    Registered:
    14 Oct 2016
    10 Jan in reply to Utkarsh
    Link to this post
    Error screenshot attached.
  5. Charles
    Charles avatar
    0 posts
    Registered:
    28 Feb 2017
    17 Mar
    Link to this post

    I am having the same issue described by Utkarsh. Would appreciate some guidance on what this might be.

    Thank you,

    Chuck Stark

  6. Nestor
    Nestor avatar
    0 posts
    Registered:
    21 May 2010
    21 Mar in reply to Charles
    Link to this post

    Same problem here, no help from Sitefinity.

    This is not a product ready for the market, at least this Thunder add-on isn't.

6 posts, 0 answered