+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Setting View permission to authenticated user only

Setting View permission to authenticated user only

2 posts, 0 answered
  1. Paolo
    Paolo avatar
    147 posts
    Registered:
    11 Jun 2009
    31 Jul 2015
    Link to this post

    Hello,

    I'm in a bad situation, I've got a Sitefinity 4.1.1501 portal that I need to do manteinance on and I had to set that only logged user can see document files. Right now the permission is "View document -> everyone"

    Since I think during years something whent wrong when I click on "Break inheritance" I got a MessageBox "Return code :12019".

     

    Is there a way I can set those view permission to only logged user via API (applying them to all the documents and set that permission as default?)

     

    Thanks

  2. Svetoslav Manchev
    Svetoslav Manchev avatar
    735 posts
    Registered:
    22 Sep 2016
    04 Aug 2015
    Link to this post
    Hello Paolo,

    You can use the API to set the permissions following that articles:
    http://docs.sitefinity.com/for-developers-permissions-api
    http://docs.sitefinity.com/for-developers-grant-and-deny-permissions
    http://docs.sitefinity.com/for-developers-query-documents

    Regarding the error, you can also try to clear the browser cache, use higher IE (IE10+) or another browser.

    You can also check the IIS settings:
    http://docs.sitefinity.com/run-projects-on-iis-7-0-and-above
    http://docs.sitefinity.com/configure-the-iis-to-host-sitefinity-projects

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
2 posts, 0 answered