+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / SF5.1 SP2 Upgrade: Module Builder content missing unless logged in as admin

SF5.1 SP2 Upgrade: Module Builder content missing unless logged in as admin

5 posts, 1 answered
  1. SteveV
    SteveV avatar
    178 posts
    Registered:
    06 Nov 2011
    19 Sep 2012
    Link to this post
    I upgraded my production website from 5.1 SP1 ealier today.  This evening I noticed that both of my Module Builder modules were no longer displaying front end content unless I was logged in to the back end.  I suspected it was a permissions error and found that all permissions for the modules were set to "Administrator Only"

    I changed the "View" permissions to "Everyone" but the problem persists.  I've tried recycling the app pool but the problem remains.  This was working fine before the 5.1 SP2 upgrade. 

    This is pretty catastrophic.  I'd appreciate any thoughts or suggestions for possible solutions.

    Thanks in advance -- Steve
  2. SteveV
    SteveV avatar
    178 posts
    Registered:
    06 Nov 2011
    19 Sep 2012
    Link to this post
    Forgot to mention that I tried to deactivate and reactivate the module with no change.

    Steve
  3. Greg
    Greg avatar
    82 posts
    Registered:
    08 Aug 2012
    19 Sep 2012
    Link to this post
    Hey Steve -

    I just upgraded a 5.0 site to 5.1 SP2 and have experienced the exact same issue. I went into my module (Content > ModuleName) and set the permissions to Everyone which did the trick for me as I can now see all module items while not logged in. By chance did you try restarting the application (app pool recycle or web.config change)?

    Good luck!
    Greg
    Answered
  4. SteveV
    SteveV avatar
    178 posts
    Registered:
    06 Nov 2011
    19 Sep 2012
    Link to this post
    Hey Greg,

    Thanks for the reply.  Hmm, interesting.  I originally set the permissions via "Administration->Permissions" and selected my module from the "Select a section" list.  Next, I set the "Who can... View donations" to "Everyone"  (see attached adminpermissions.png).  Next I recycled the app pool and no luck.

    I hadn't noticed the permissions settings under Content->Module Name as you indicated.  Looking at those, I see the same "Who can... View Donations" settings, but those are set to "Administrators only" (see modulepermissions.png). 

    Maybe Telerik can explain why that there would be 2 places to set module permissions.  But clearly the permissions in Content->Module Name are the ones that matter.

    Not to mention that it would be interesting to know why ALL of the permissions in my module builder modules were reset to administrator.

    Thanks again--Steve
  5. Stephen2
    Stephen2 avatar
    94 posts
    Registered:
    05 Feb 2012
    26 Sep 2012
    Link to this post
    Confirmed this bug... Sitefinity 5.1SP2.

    Dynamic Content (Module Builder) permissions can only be correctly set through "Administration -> Permissions".

    Setting them in the "Content -> <ContentType> -> Permissions" does NOT actually effect the permissions...

    This is clearly a UI disconnect and fairly nasty little bug, but at least you guys helped me find the answer.  THANK YOU!

    Sitefinity -  I'll be lodging a support ticket linking to this forum thread so this can be corrected (hopefully in time for 5.2)
5 posts, 1 answered