1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Submit form entry error

Submit form entry error

4 posts, 0 answered
  1. Adriano
    Adriano avatar
    4 posts
    Registered:
    23 Dec 2010
    07 Feb 2011
    Link to this post
    Hi,

    I'm having a lot of problems to use a form. The form I'm trying to use has 9 textboxes and 9 multiple choices. Some controls are required.
    The sometimes I can create the hole form, but when I attempt to create a response the controls are displayed on a different order and when I click the "submit" button I get a javascript error (an alert with the message "undefined").

    There is no custom control, only Sitefinity Form Controls. None of the controls I put on the form has advanced properties changed.


    Note: I'm using Sitefinity version 4.0.1098.0
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    07 Feb 2011
    Link to this post
    Hello Adriano,

    Could you tell us whether you have change some of the properties of the form widgets after you dropped them on  a page?

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Adriano
    Adriano avatar
    4 posts
    Registered:
    23 Dec 2010
    07 Feb 2011
    Link to this post
    Hi,

    In every control i've changed the "Name for developer" property.
    In some textboxes i've checked the "Mark required" option.
    In every multiple choice controls i've changed the default items and the appearance to "inline".
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    12 Sep 2017
    11 Feb 2011
    Link to this post
    Hi Adriano,

    I was trying to replicate the issue locally with the latest build, but the response was properly processed. Can you try to drop the widgets on a page without changing the "name for developers" and see whether the problem will appear. It is possible that there is some conflict with the values you set.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
4 posts, 0 answered