+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / The specified cryptographic algorithm is not supported on this platform.

The specified cryptographic algorithm is not supported on this platform.

10 posts, 0 answered
  1. Carlos Daniel
    Carlos Daniel avatar
    5 posts
    Registered:
    05 Mar 2012
    07 Mar 2012
    Link to this post
    I installed sitefinity 5 in Windows XP.

    When I install Sitefinity everything is ok. So I log on with user and password , after that a form for adding users is shown, I fill the fields and I try to add the user, and It just stops. I mean nothing happend, it seems it is working.

    And when I try to log on with the supposly user I have added, the message :
    "The specified cryptographic algorithm is not supported on this platform" appears.

    " System.Security.Cryptography.CapiNative.AcquireCsp(String keyContainer, String providerName, ProviderType providerType, CryptAcquireContextFlags flags, Boolean throwPlatformException) +135
    System.Security.Cryptography.SHA256CryptoServiceProvider..ctor() +55..."

    Can someboy tell me what is going on, please?
  2. Svetoslav Petsov
    Svetoslav Petsov avatar
    456 posts
    Registered:
    24 Sep 2012
    12 Mar 2012
    Link to this post
    Hello Carlos,

     Unfortunately the SHA256 algorithm that we use for encrypting is not supported in Windows XP. Here's an article on this:
    http://social.msdn.microsoft.com/Forums/en/csharplanguage/thread/04328b17-aeea-439a-9574-e6e0a7ce8040 
    Actually we do not officially support Windows XP, so such errors are completely possible if you are running under XP.

    Kind regards,
    Svetoslav Petsov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Nick
    Nick avatar
    2 posts
    Registered:
    23 Jan 2012
    14 Mar 2012
    Link to this post
    Where does one go to get a previous version?  In the admin area for product downloads, only 5.0 is listed.
  4. Don
    Don avatar
    2 posts
    Registered:
    15 Mar 2012
  5. Boyan Barnev
    Boyan Barnev avatar
    1429 posts
    Registered:
    02 Dec 2016
    02 Apr 2012
    Link to this post
    Hello,

    @ Nick, you can download Sitefinity 4.4 version form the all products versions page form your Sitefinity account here:
    http://www.sitefinity.com/account/your-products/product-versions.aspx?pid=725

    @Don Thank you very much for suggesting this, I have already communicated it with our documentation team and we'll be reflecting the proposed changes soon.

    Greetings,
    Boyan Barnev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Moj
    Moj avatar
    1 posts
    Registered:
    17 Feb 2012
    25 Apr 2012
    Link to this post
    I works :))
    Go to the registry and find "Microsoft Enhanced RSA and AES Cryptographic Provider (Prototype)". Export this key, remove "(Prototype)" and install (merge) the new reg file. 

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\Defaults\Provider\Microsoft Enhanced RSA and AES Cryptographic Provider]
    "Image Path"="rsaenh.dll"
    "Type"=dword:00000018
    "SigInFile"=dword:00000000

  7. Carlos Daniel
    Carlos Daniel avatar
    5 posts
    Registered:
    05 Mar 2012
    11 May 2012
    Link to this post
    Thanks for your help
  8. Don
    Don avatar
    2 posts
    Registered:
    15 Mar 2012
    11 May 2012
    Link to this post
    Yes, registry edit works great.  Thanks.
  9. Asit
    Asit avatar
    87 posts
    Registered:
    07 Nov 2009
    12 Jul 2012
    Link to this post
    I have already the same registry keys in my XP, but still it's not working.
  10. Sriram
    Sriram avatar
    1 posts
    Registered:
    08 Sep 2010
    26 Nov 2012
    Link to this post
    hi.. how can we resolve this probllem to work on windows xp environment
10 posts, 0 answered