+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Upgrade from 6.0.4210.0 to 6.2.4210.0 now throws an error

Upgrade from 6.0.4210.0 to 6.2.4210.0 now throws an error

8 posts, 0 answered
  1. John
    John avatar
    51 posts
    Registered:
    11 Apr 2013
    15 Nov 2013
    Link to this post
    I copied all my sitefinity files from a working production site to a local drive, made a copy of the DB and hooked the local copy to that db. The local copy ran correctly. I then used the 6.2.4210.0 project manager to upgrade the project/site and now I get the following error:
    "Could not load file or assembly 'Telerik.Sitefinity, Version=6.0.4210.0"
    What's up and how do I fix it?
  2. Jonathan
    Jonathan avatar
    119 posts
    Registered:
    19 Dec 2012
    15 Nov 2013 in reply to John
    Link to this post
    Did you follow the upgrade path here.  You will need to make the web.config changes and other for both  6.0 -> 6.1 and 6.1 -> 6.2

    http://www.sitefinity.com/documentation/documentationarticles/installation-and-administration-guide/upgrade

    Happy Coding This!
  3. John
    John avatar
    51 posts
    Registered:
    11 Apr 2013
    19 Nov 2013 in reply to Jonathan
    Link to this post

    I just went into project manager and selected upgrade.(As directed in a document that I was referred to.) I would expect the project manager to have some awareness of the versioning.

    It's getting frustrating when I go to read the documentation and I get different instructions each time I go online and search the documentation.  I think if Telerik is going to sell this product they need to seriously look  at the documentation and get it inline with the real world.

  4. John
    John avatar
    51 posts
    Registered:
    11 Apr 2013
    19 Nov 2013 in reply to Jonathan
    Link to this post
    I just followed the documentation located at http://www.sitefinity.com/documentation/documentationarticles/upgrading-your-sitefinity-6.0-project-to-the-latest-version
    I didn't see anything aabout having to go from 6 to 6.1 to 6.2?
  5. Jonathan
    Jonathan avatar
    119 posts
    Registered:
    19 Dec 2012
    19 Nov 2013 in reply to John
    Link to this post
    But notice in 6.1 -> 6.2 there are additional web.config changes
  6. John
    John avatar
    51 posts
    Registered:
    11 Apr 2013
    19 Nov 2013 in reply to Jonathan
    Link to this post
    Kind've figured those would be included in the document detailing "6.0 to the latest version". 
  7. Darrin Robertson
    Darrin Robertson avatar
    105 posts
    Registered:
    18 Jul 2004
    20 Nov 2013
    Link to this post

    Do you have any custom dlls\widgets that reference Sitefinity dlls. It may be that that is throwing the error.

    To ensure you have the right dlls delete all the Sitefinity ones in the bin directory and then from the Project Manager exe location you will find a folder called _empty project.

    From the bin directory there take all the SF dlls and copy to your bin folder.

    Do you have the site in a VS soln? Its much easier if you do.

  8. John
    John avatar
    51 posts
    Registered:
    11 Apr 2013
    20 Nov 2013 in reply to Darrin Robertson
    Link to this post

    That was it. I had one 3rd party widget that needed to be updated.

     

    Thanks

8 posts, 0 answered