+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Way to Disabling Auto Fill "Title for search engines"?

Way to Disabling Auto Fill "Title for search engines"?

5 posts, 0 answered
  1. Mark
    Mark avatar
    4 posts
    Registered:
    24 May 2013
    24 May 2013
    Link to this post

    Hi,

    I was wondering if is there any way to disable the Auto fill for "Title for search engines" whenever you are typing on the "Name" field? We personally find this sometimes Inappropriate. especially when we only intent to edit the "Name" only

    Thanks :) 
  2. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    28 May 2013
    Link to this post
    Hello Mark,

    There are some SEO reasons for mirroring the "Title for search engines" field. This mirroring can be easily disabled. There are two ID fields in the advanced settings in Administration that you can change in order to do this and in the attached pictures you can find the path to them. In "Mirrored control id" you can change "PagesNameFieldControl" with  "codeBehindTypeElement" or "SeoTitleFieldControl" for example. After saving these changes "Title for search engines" field can be edited separately from the "Name" field.

    Regards,
    Kaloyan
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Mark
    Mark avatar
    4 posts
    Registered:
    24 May 2013
    28 May 2013 in reply to Kaloyan
    Link to this post
    Hi Kaloyan,

    I not sure with the results. but I tried editing published pages and It seem to be working. but when I create a new page the auto fill function is still there. is this expected on creating a new page?


    Thanks :)

  4. Kaloyan
    Kaloyan avatar
    272 posts
    Registered:
    08 Dec 2016
    29 May 2013
    Link to this post
    Hi Mark,

    have you changed the values for "Mirrored control id" in both FrontendPagesEdit and FrontendPagesCreate? Editing and creating a page are two separate processes and you have to change two separate options to disable the auto fill. I have tried to disable it on my test project and everything works as expected for creating and editing a page.

    Regards,
    Kaloyan
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Mark
    Mark avatar
    4 posts
    Registered:
    24 May 2013
    03 Jun 2013 in reply to Kaloyan
    Link to this post
    Hi Kaloyan,

    I think it would be best if I leave the Create a new page auto fill and disable it on Edit page.

    Thank you very much for you help :)

    Regards,
5 posts, 0 answered