+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Where's my widget?!

Where's my widget?!

8 posts, 0 answered
  1. Richard
    Richard avatar
    49 posts
    Registered:
    13 Jul 2010
    21 Aug 2012
    Link to this post
    Ok, so I have followed the MVC short video and attempted to implement my own MVC implementation for a simple form.

    The folder structure can be seen in WheresMyWidgetFolder with the ControllerToolboxItem set up in WheresMyWidget.PNG.

    This has been built/rebuilt, etc and a new page set up accordingly. However, when I go to add content to the page and search for the MVC tools, all I see is Widgets.PNG.

    Where have I gone wrong?! The only thing that stands out to untrained yes is the namespace but surely, SURELY that won't be the reason for it not showing is it?

    Do I need to change my web config to bring this widget through? I'm sad. 
  2. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    21 Aug 2012
    Link to this post
    That doesn't look like the list of a page based on a template set to MVC Pure or Hybrid mode...? (Defiantly not pure anyway)
  3. Richard
    Richard avatar
    49 posts
    Registered:
    13 Jul 2010
    21 Aug 2012
    Link to this post
    I know it doesn't..but it is a page template set to hybrid :'(
  4. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    21 Aug 2012
    Link to this post
    Well that's certainly odd

    ...what if you use Thunder to create a new widget (couple clicks), build, then see if that shows up?
  5. Richard
    Richard avatar
    49 posts
    Registered:
    13 Jul 2010
    21 Aug 2012
    Link to this post
    I'll give that a try tomorrow.

    For now, I need to step away from the computer before the computer vacates the building at high velocity.
  6. Richard
    Richard avatar
    49 posts
    Registered:
    13 Jul 2010
    22 Aug 2012
    Link to this post
    Wowsers this is infuriating!!!

    So I've downloaded SF Thunder and tried adding a widget this way. No joy.

    Might have a clue with the issue though since when I try adding an MVC widget, I get an "Object reference not set to an instance of an object" - could that be the namespace issue I alluded to above?

    i.e. can you change your solution / web app name / namespace and add widgets?

    Twenty minutes in, nearly in tears already :'(

    Right. Seeing as this is right at the start. I'm going to treat myself to setting up the new VS and try again from scratch.
  7. Pascal
    Pascal avatar
    9 posts
    Registered:
    22 Nov 2010
  8. Richard
    Richard avatar
    49 posts
    Registered:
    13 Jul 2010
    23 Aug 2012
    Link to this post
    Cheers Pascal.

    Yeah I've set up a new project and kept the namespaces the same. Works absolutely fine.

    Perhaps it's just an ingenious way of promoting Sitefinity :D

    At least I know it's not me going completely mad!
8 posts, 0 answered