+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Admin page rendering extremely slow

Admin page rendering extremely slow

14 posts, 0 answered
  1. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    11 Mar 2010
    Link to this post
    I am using Sitefinity 3.7.2022.220. For some reason, it took me about 80 seconds to login to Sitefinity. Any idea why?

    Thanks,
    Pik
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    11 Mar 2010
    Link to this post
    Hello Pik Lee,

    We are not able to reproduce such problems. You could face this problem if you have a quite big page data source ( 15000 pages ). From 3. 7 SP3 Sitefinity will be able to handle 1 billion pages.

    You can check whether any custom code does not run in the background of a login. You can observe the Request/Response with HttpWatch or Fiddler. You could also use  SQL Server Profiler to see whether something is going wrong with the database.

    All the best,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    11 Mar 2010
    Link to this post
    Thanks for the reply. The web site is working fine and has no problem Just the Sitefinity login page. Is it a table in the database that causing this? Do you know which table?

    Thanks,
    Pik

  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    11 Mar 2010
    Link to this post
    Hi Pik Lee,

    Nolics ORM executes the queries to the database. Using SQL Profiler you can observe the queries that are made when you are trying to log in.  At my end the login is conducted for about one second.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    12 Mar 2010
    Link to this post

    Thanks for the info. Below is the httpwatch results for my administration page,

    + 0.000  81.822 906 39395 GET 200 text/html; charset=utf-8 https://[website]/sitefinity/websites/portal/sitefinity/Admin/Default.aspx

    Not sure if this has something to do with the sql server or IIS server? I am not a network person. Can anyone tell me where do I look for to improve this performance of the administration page?

    Thanks,
    Pik
  6. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    12 Mar 2010
    Link to this post
    Is it just the first load of the login that is slow?

    Try this

    - Login [yes, I know it's slow]
    - Logout
    - Login again [is it fast this time?]

    IIS, by default, will put an application to sleep if its unused for several minutes (20 minutes I think).  Using the test above, if the 2nd login is fast then this is probably what is happening.  (You can ping the application every 15 minutes or so to keep the application alive.)

    On the other hand, if the 2nd login is still slow then something else is going on.  How many Sitefinity pages do you have?  What types of custom have you added?  Are you using shared hosting?

    Gabe Sumner
    Telerik | Sitefinity CMS
  7. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    12 Mar 2010
    Link to this post
    Pik - Is the entire admin site slow?  What happens when you click on the pages section and drill down?

    We have lots of pages/permissions and our admin site is really slow.

    J
  8. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    14 Mar 2010
    Link to this post
    Hello Jason M,

    There are improvements regarding number of pages that Sitefinity can handle in 3.7 SP3. The SP3 is going to be released next week. If you have problems related to the backend performance when you access the Dashboard or All Pages the SP3 will sort out the issue.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  9. MB
    MB avatar
    302 posts
    Registered:
    09 Jan 2005
    14 Mar 2010
    Link to this post
    I've got this issue with one of my sites.

    The site in question was a V3.5 that was upgraded to V3.7

    As a 3.5 site, the admin pages loaded very quickly, and there was no problem.

    As a 3.7 site, the admin pages that list site-pages, site-templates or site-maps are all *veeeerrrryyy* slow to load.

    Hence, logging into the site with a start-screen of say, Dashboard or Sitemap... takes for ever.

    However, if I change the start-screen to something like, "Files" - then it logs in pretty quick.

    I figure that it's got to be a database problem, perhaps something happened when the site was upgraded, but I've never gotten to the bottom of it to pinpoint the exact cause, and becasue this particular site is not edited much, I have just learned to live with it... especially as it has no effect on the public site, which still runs like a rocket.

    -- MB.
  10. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    15 Mar 2010
    Link to this post
    Thanks for all the response.
     
    The page render very slow when I log in. MB is correct. When I "change start screen" to "Files", it render very fast when log in. The page is rendering slow when I click on "Dashboard" tab and "Pages" tab.

    Hopefully the 3.7 SP3 will fix this issue.

    Thanks,
    Pik
  11. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    15 Mar 2010
    Link to this post
    Aha.  I'll try upgrading to 3.7 SP3 on my DEV server and will let you know how it goes!

    J
  12. dcardine
    dcardine avatar
    4 posts
    Registered:
    10 Aug 2006
    17 Mar 2010
    Link to this post
    I'm running 3.7. how do i know if i have SP3 installed? Someone else set my site up and the admin cp runs painfully slow. Especially when loading pages/templates and adding links and images from libraries etc.
  13. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
  14. Jason M
    Jason M avatar
    108 posts
    Registered:
    15 Jan 2007
    31 Aug 2010
    Link to this post
    After deploying 3.7 SP3 to production we noticed the admin pages load much quicker.  It would take ~20 seconds to drill down a couple levels and this now takes use ~5 seconds.  Much better!

    J
Register for webinar
14 posts, 0 answered