+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Error 'Illegal Characters in Path'

Error 'Illegal Characters in Path'

4 posts, 0 answered
  1. Yosief
    Yosief avatar
    27 posts
    Registered:
    20 Mar 2008
    31 Aug 2011
    Link to this post
    Hi All

    Upon checking the event log of the web server hosting one of our sites, I found an entry about some illegal characters in the Request.Url. Below is the full details of the entry:

    =============================================================================================

    Event Type:        Warning

    Event Source:    ASP.NET 2.0.50727.0

    Event Category:                Web Event

    Event ID:              1309

    Date:                     8/30/2011

    Time:                     2:41:53 PM

    User:                     N/A

    Computer:          SERVER01

    Description:

    Event code: 3005

    Event message: An unhandled exception has occurred.

    Event time: 8/30/2011 2:41:53 PM

    Event time (UTC): 8/30/2011 6:41:53 PM

    Event ID: 555baad8c80146268963d2b03ebd9dd4

    Event sequence: 316

    Event occurrence: 53

    Event detail code: 0

     

    Application information:

        Application domain: /LM/W3SVC/1582590123/Root-1-129591755681331753

        Trust level: Full

        Application Virtual Path: /

        Application Path: C:\Inetpub\wwwroot\Website01

        Machine name: SERVER01

     

    Process information:

        Process ID: 65488

        Process name: w3wp.exe

        Account name: NT AUTHORITY\NETWORK SERVICE

     

    Exception information:

        Exception type: ArgumentException

        Exception message: Illegal characters in path.

     

    Request information:

        Request URL: http://www.Website01.com/folder01/Mediibil4!|4!|°aSummaries.aspx?YinalÃâ€at&Page=4

        Request path: /folder01/Mediibil4!|4!|°aSummaries.aspx

        User host address: xxx.xxx.x.xxx

        User: 

        Is authenticated: False

        Authentication Type: 

        Thread account name: NT AUTHORITY\NETWORK SERVICE

     

    Thread information:

        Thread ID: 5

        Thread account name: NT AUTHORITY\NETWORK SERVICE

        Is impersonating: False

        Stack trace:    at System.IO.Path.CheckInvalidPathChars(String path)

       at System.IO.Path.GetExtension(String path)

       at System.ServiceModel.Activation.HttpModule.ProcessRequest(Object sender, EventArgs e)

       at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

     

    Custom event details:

     

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    ==========================================================================================


    The url '/folder01/MediaSummaries.aspx' is a valid path. The problem is the funny characters 'bil4!|4!|°' between 'Medi' and 'aSummaries.aspx'.

    Any help about the cause of the problem is highly appreciated.

    Thanks
    Yosief Kesete
  2. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    02 Sep 2011
    Link to this post
    Hi Yosief,

    I'm not sure how this happened. Is your page named MediaSummaries.aspx? Can you check in the backend if you haven't inserted some extra character by any chance between Medi and aSummaries as it seems that the wrong symbols appear there.

    Greetings,
    Lubomir Velkov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  3. Yosief
    Yosief avatar
    27 posts
    Registered:
    20 Mar 2008
    02 Sep 2011
    Link to this post
    Hi Lubomir

    Yeah my page is named MediaSummaries.aspx. I don't have such symbols in the back end.

    Any other ideas??
  4. Lubomir Velkov
    Lubomir Velkov avatar
    688 posts
    Registered:
    03 Nov 2014
    03 Sep 2011
    Link to this post
    Hello Yosief,

    So when you access this page from the backend it is working normally? Maybe this is some hacking attempt that exploits some well known server vulnerability?

    Best wishes,
    Lubomir Velkov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

Register for webinar
4 posts, 0 answered