+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / library file not replacing

library file not replacing

6 posts, 0 answered
  1. Rabindra
    Rabindra avatar
    106 posts
    Registered:
    17 May 2009
    25 Mar 2010
    Link to this post
    Hi,
    I am trying to replace a .doc file in library module. I saw change in KB but the actual file isn't replaced.
    could you help?

    I am using 3.7 SP2
  2. Rabindra
    Rabindra avatar
    106 posts
    Registered:
    17 May 2009
    25 Mar 2010
    Link to this post
    Replacing didn't help.
    This time I deleted the old file. Double checked on the front end to see if the link to the file worked. It didn't so that was fine.
    Then I uploaded the new file but with the same name. Surprisinly I am getting the same old file when I try to download it from the backend library. The link was still not working in front end.
    I tested with two different files (.doc and .pdf) and same result.
    So, I am guessing, even though the file was deleted, the system is not really deleting the data from the sql server. It is only deleting the reference.
    Am I right?
    Can this be fixed soon? It's very urgent.
  3. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    25 Mar 2010
    Link to this post
    Hi Rabindra,

    Thank you for using our services.

    Have you tried the re-upload functionality when you edit some items. I have attached a small sample screen cast to illustrate how it works. The video has been made with Sitefinity 3.7 SP2.

    All the best,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  4. Rabindra
    Rabindra avatar
    106 posts
    Registered:
    17 May 2009
    26 Mar 2010
    Link to this post
    I really don't know. I had already tried what you had done which I wrote on my first post.
    I will have to test it again.
  5. Rabindra
    Rabindra avatar
    106 posts
    Registered:
    17 May 2009
    12 May 2010
    Link to this post
    Hi there,
    I am still having this problem. Your video shows reuploading replaces the file but mine doesn't.
    May be when I upgraded from SP1 to SP2 I missed out some files to replace. Could you please tell me which files I need to replace for this module?

    thanks
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    12 May 2010
    Link to this post
    Hi Rabindra,

    Thank you for getting back to me.

    If you are not using external templates for the Images and Documents back-end controls, then you should not worry about forgetting files. If however you use them you should merge yours with  the external templates for your current version of Sitefinity. However I doubt that this issue is coming from this. I have replied to your support ticket with similar issue. As I noted there this might be IIS caching your files in memory. You can try with application pool recycle to verify if this is the cause.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Register for webinar
6 posts, 0 answered