+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Mirror db in Production server

Mirror db in Production server

4 posts, 0 answered
  1. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    03 Feb 2010
    Link to this post
    I am trying to move the site from development to production. I've created a new database in production sql server and try to retore the db. I noticed the production db's  ApplicationID in all the tables do not match the one in the development. And my site in production is not working. Anyone has any issue on retoring the db? How do you mirror the db in both server?

    Thanks,
    Pik
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    03 Feb 2010
    Link to this post
    Hi Pik Lee,

    Create a backup and restore the backup on the production. Another option is using third party database replication and schema comparison tools.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  3. Pik Lee
    Pik Lee avatar
    142 posts
    Registered:
    13 Aug 2012
    04 Feb 2010
    Link to this post
    Thank you for the information. The site is working now. But the admin page is not. Here is the error message when I tried to open the admin page.

    Thanks,
    Pik
     

    Invalid object name 'SYSCTRL.SYSCTRL.web_users'.

    Invalid object name 'XXX'.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Data.SqlClient.SqlException: Invalid object name 'xxx'.

    Source Error:

    Line 27: 	void Login1_Authenticate(object sender, AuthenticateEventArgs e)
    Line 28: 	{
    Line 29: 		e.Authenticated = UserManager.Default.ValidateUser(this.Login1.UserName, this.Login1.Password);
    Line 30: 	}
    Line 31: 
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    04 Feb 2010
    Link to this post
    Hi Pik Lee,

    This problem occurs when you are restoring a databse to another server and if you have changed the database name or dbousername. You can use ALTER SCHEMA dbo TRANSFER oldSchema.TableName.

    Sincerely yours,
    Ivan Dimitrov
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
Register for webinar
4 posts, 0 answered