+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / NewsArchive list not expanding

NewsArchive list not expanding

6 posts, 0 answered
  1. Viktoriya
    Viktoriya avatar
    20 posts
    Registered:
    29 Jul 2010
    05 Aug 2010
    Link to this post
    Hi there,

    I'm trying to display a newsarchive list in one of our pages. I have included it into the page and have set it so it is collapsed by default. I must have something wrong as the list doesn't expand when I click on the top level(?).
    If I set it so that the list is expanded by default it displays all items and upon clicking the top level it collapses but after

    Could you please help me? What am I missing?

    Thanks!
    Vix
  2. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    10 Aug 2010
    Link to this post
    Hi Viktoriya,

    I am sorry I am unable to reproduce the issue. I have added a news archive control on my page and set the isExpandedList property to false. The control behaves as expected. Could you please check your concrete version of Sitefinity so that we can test this your version? You can follow this article to find out your version.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Scott Rozman
    Scott Rozman avatar
    93 posts
    Registered:
    10 Oct 2012
    28 Jan 2011
    Link to this post
    I am currently having the same issue, if I set expanded to false, it shows collapsed to all of the Years, but if I click on a year to expand, the filter is reset and the items displayed match that year, but the tree does not stay open to show the Months. It pops open for a split second and then collapses.
    Additionally, if I set expanded to true, it does not collapse when I click on year nodes.

    I am running
    Sitefinity 3.7.2136.240:1
    and I've left the problem on a page you can see.

    Thanks in advance for your help.

    Scott




  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    03 Feb 2011
    Link to this post
    Hello Scott Rozman,

    Thank you for joining the conversation.

    The tree should be expanded from a + image which occurs to each tree item. On your page it seems that this expand icon is hidden because of your CSS rules. Your tree view must have the above styles:

    .RadTreeView .rtPlus, .RadTreeView .rtMinus {
    }
    .RadTreeView .rtPlus, .RadTreeView .rtMinus {
        margin-left: -18px;
        margin-right: 7px;
    }
    .RadTreeView .rtMinus {
        background-position: 0 -11px;
    }
    .RadTreeView .rtPlus, .RadTreeView .rtMinus {
        background-repeat: no-repeat;
        cursor: pointer;
        display: inline-block;
        font-size: 0;
        height: 11px;
        margin: 6px 7px 0 -18px;
        padding: 0;
        vertical-align: top;
        width: 11px;
    }
    .rtIn, .rtSp, .rtMid, .rtLI, .rtUL {
        line-height: 16px !important;
        list-style: none outside none;
    }

    Also it seems that the arrow sprites you are using are in the same color as the background of your body element and they blend in together.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Scott Rozman
    Scott Rozman avatar
    93 posts
    Registered:
    10 Oct 2012
    04 Feb 2011
    Link to this post
    Thanks, Radoslav.
    It turned out that the site I was working on had an archivetemplate.ascx with
    EnableEmbeddedSkins="false" EnableEmbeddedBaseStylesheet="false"

    Some time ago, I had extracted the embedded stylesheets and added it to my theme, so I could modify it vs. using !important on select rules, but I am no longer doing that.

    I forgot this was the case, so I wasn't seeing the sprite arrows at all, despite needing to also change their color.

    Now I just need to work on the issue of getting the selected node expanded on post-back.
    http://www.sitefinity.com/devnet/forums/sitefinity-3-x/bugs-issues/news-archive-tree-problem.aspx
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    10 Feb 2011
    Link to this post
    Hi Scott Rozman,

    What  you should do is to get the year value from the query string and then find the node which such value and expand it. You can check an example of how to expand tree nodes here.

    All the best,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
6 posts, 0 answered