+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / PageMethod not working?

PageMethod not working?

2 posts, 0 answered
  1. Josh
    Josh  avatar
    25 posts
    Registered:
    28 Apr 2009
    28 Oct 2010
    Link to this post
    Hi,

    I am trying to call a webmethod

    function DeleteContent() {
         PageMethods.removeLibrary('14442c71-f094-4f56-aac5-686876c9ba61', OnSucceeded, OnFailed);        
     }

    which I have added the modules page from the newsItemEdit.ascx template and it seems to have successfully executed as indicated by hitting the OnSucceeded method but when i try to trace through it it never really enters the PageMethod and it never executes any of the code in the page method.  the message that is displayed looks like the source code of the beginning of the page.  Am I doing something wrong here?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    28 Oct 2010
    Link to this post
    Hello Josh ,

    it seems to have successfully executed as indicated by hitting the OnSucceeded method but when i try to trace through it it never really enters the PageMethod and it never executes any of the code

    Most probably there is a problem with the js code you use to call the web service. It is not possible to get a response from the call back if the method you use to call the web service is not called. You could also put a break point in the web method. Make sure that you have registered the web service with ScriptManager.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered