1-888-365-2779
+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Rad editor on generic content issue

Rad editor on generic content issue

6 posts, 0 answered
  1. Vangelis
    Vangelis avatar
    153 posts
    Registered:
    07 Jan 2006
    19 May 2007
    Link to this post
    Hi,

    I have on a page Generic content and I use bullet list from toolbar. I check on source and see that it's correct
    <ul>
    <li>line 1</li>
    <li>line 2</li>
    <li>line 3</li>
    <li>line 4 </li>
    </ul>

    but when I do a preview of the page there is also an extra line space and also there is no bullet list

    I check this also with numbered list but there are no numbers in front
    ><ol><li>line 1 </li><li>line 2 </li><li>line 3 </li><li>line 4 </li></ol>

    Do I miss something? It's not working WYSIWYG. I check this on both on Firefox 2 and IE 7

    Best regards

    Vagelis
  2. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    21 May 2007
    Link to this post
    Hello Vagelis,

    Thanks a lot for this issue. We will take it into consideration and fix it. You can work around this problem by specifying the type of the list.

     For example:

    <ul style="list-style-type: circle;">

     <li>list 1</li>

     <li>list 2</li>

     <li>list 3</li>

    </ul>

    Type can be: disc, square, circle.

    I hope this will help you to some extent.

    Regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Vangelis
    Vangelis avatar
    153 posts
    Registered:
    07 Jan 2006
    21 May 2007
    Link to this post
    Hello Pepi,

    I tried as you've suggested but the result it's not also good. It now displays a circle but there is no good allignment and still there is an extra line separation for each item. On Rad editor edit and preview is displayed well but on page preview or publish it's a mess. I tried also with a tab on each of these items and I had a numbered list after and the numbers went out of the border of edit section. It would be easiest to understand If I could send you print screens of it.

    Best regards

    Vagelis
  4. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    22 May 2007
    Link to this post
    Hello Vagelis Kretsimos,

    You can try to fix alignment by setting some padding of the list.

    For example:

    <ul style="list-style-type: circle;padding-left: 15px;">
      <li>list 1</li>
      <li>list 2</li>
      <li>list 3</li>
    </ul>

    But if this does not help, it will be very useful if you could send some screenshots of your page preview and html of the unordered list (the code when you go in html mode in RadEditor)

    Greetings,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Vangelis
    Vangelis avatar
    153 posts
    Registered:
    07 Jan 2006
    23 May 2007
    Link to this post
    Hello Pepi,
     
    I'm sending you attached the print screens of the issue.
     
    Best regards 
    Vagelis Kretsimos
  6. Pepi
    Pepi avatar
    981 posts
    Registered:
    31 Jan 2017
    23 May 2007
    Link to this post
    Hello Vagelis Kretsimos,

    The screenshots shows that your alignment problem is not in Sitefinity; Sitefinity just loads your CSS files. As I mentioned in my previous post,  you should set some padding of the list.

    Example:

    CSS file:
    .security {
     list-style-type: circle;
     padding-left: 15px;">
    }

    ASPX:
    <ul class=”security”>
     <li>antivirus</li>
     <li>antispyware</li>
     <li>firewalls</li>
    </ul>

    Here are some links that will help you with CSS:

    http://css.maxdesign.com.au/listamatic/
    http://www.tizag.com

    http://www.w3schools.com/css/

    Also, it will be very useful for you to install FireBug for FireFox that will give you the opportunity to debug your CSS. You can download it from http://www.getfirebug.com/

    I hope that this information will be helpful for you.

    Regards,
    Pepi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
6 posts, 0 answered