+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Server Error in "/" Application

Server Error in "/" Application

15 posts, 0 answered
  1. Brian Javeline
    Brian Javeline avatar
    12 posts
    Registered:
    11 Dec 2009
    11 Jan 2011
    Link to this post
    I am trying to correct a webpage that has a broken link.  I have tried to first remove the broken link, and have also tried to just replace the broken link.  This is the following message I get everytime I try to Publish the changes.

    Server Error in '/' Application.


    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

     

    <!-- Web.Config Configuration File -->

     

    <configuration>

        <system.web>

            <customErrors mode="Off"/>

        </system.web>

    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

     

    <!-- Web.Config Configuration File -->

     

    <configuration>

        <system.web>

            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

        </system.web>

    </configuration>

     

  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    11 Jan 2011
    Link to this post
    Hi Brian,

    It would be good if you turn off the custom errors mode, so the actual error could appear.  For more information please check MSDN.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Brian Javeline
    Brian Javeline avatar
    12 posts
    Registered:
    11 Dec 2009
    11 Jan 2011
    Link to this post
    I received a reply that it was a telerik server issue and that I should try again.  I tried again and the same error occurs.  Brian
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    14 Jan 2011
    Link to this post
    Hello Brian,

    OK. What is the error? Can you paste the stack trace here or attach a screnshot?

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Brian Javeline
    Brian Javeline avatar
    12 posts
    Registered:
    11 Dec 2009
    14 Jan 2011
    Link to this post
    I am unsure how better to reply, since the entire error I get is displayed in my opening thread.

    Here is what I am doing, and perhaps you will see how simple it is to cause the error.

    Currently we have a broken link inside my Help documentation. 

    When looking at
    http://help.myonlinetoolbox.com/Templates/TemplateFolders.aspx
    If you scroll down to the bottom, you will see a spot that says

    You are now ready to add Templates to either the default folder or group folders. 

    I am looking to link "add Templates" to
    http://help.myonlinetoolbox.com/Templates/TemplateTasks.aspx

    I am able to choose the Icon that allows me to insert the above link.
    I am also able to save it.
    The error occurs when I attempt to Publish the page.

    Brian
  6. jmmy
    jmmy avatar
    3 posts
    Registered:
    04 Dec 2010
    17 Jan 2011
    Link to this post
    I got same error when i just create the new Library for images and give title and description
    below is the error .. i am trying to solve it but i am failed to do so.. 
    before this error we have problem with IIS_USRS primssion problem which i set then this error ocures
    all website works fine.

    Object reference not set to an instance of an object.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    Line 61: 
    Line 62: 		LibraryDescriptionInfo libraryDescription = LibraryDescriptionController.GetByID(libraryID);
    Line 63: 		libraryDescription.Description = description;
    Line 64: 		libraryDescription.Credits = credits;
    Line 65: 		LibraryDescriptionController.Update(libraryDescription);

    Source File: c:\inetpub\vhosts\adecentidea.com\httpdocs\App_Code\LibraryDescriptionEdit.cs    Line: 63

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       LibraryDescriptionEdit.LibraryDescription_Saved(Object sender, CommandEventArgs e) in c:\inetpub\vhosts\adecentidea.com\httpdocs\App_Code\LibraryDescriptionEdit.cs:63
       Telerik.Libraries.WebControls.Admin.LibraryEdit`1.OnSaved(CommandEventArgs e) +270
       Telerik.Libraries.WebControls.Admin.LibraryEdit`1.SaveLibrary(String commandName) +805
       Telerik.Libraries.WebControls.Admin.LibraryEdit`1.Button_Command(Object sender, CommandEventArgs e) +144
       System.Web.UI.WebControls.LinkButton.OnCommand(CommandEventArgs e) +108
       System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +135
       System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +175
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1565
    
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    18 Jan 2011
    Link to this post
    Hi,

    The screenshot shows that you are getting an error from some custom classes which are not implemented by us

    • ADecentIdea.DataAccess.SqlDAtaProvider.SqlDataProvider.SaveLibraryDesctiption
    • LibraryDescriptionNew.LibraryDescription_Saved
    The error is thrown because of some problems with the datalayer you have implemented which inserts data into the database.

    Object reference not set to an instance of an object means that you are not handing the null objects. Somewhere you are trying to use an object which is null.

    Please check your custom code in \App_Code\LibraryDescriptionEdit.cs

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Brian Javeline
    Brian Javeline avatar
    12 posts
    Registered:
    11 Dec 2009
    18 Jan 2011
    Link to this post
    OK, but what about me and the original error?   I do not mind giving you permission to log in and try this yourself since all I am doing is trying to insert a link.  If that is OK, please advise and I can give the details down to an exact science.  Brian
  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    19 Jan 2011
    Link to this post
    Hello Brian,

    The error you see is not the actual error and it does not provide information what the issue could be. Error details are disabled by the application from your config.

    To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    You can check App_Data/sitefinity.log. This is the application log file and there should be some stack trace about the error you are getting.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Brian Javeline
    Brian Javeline avatar
    12 posts
    Registered:
    11 Dec 2009
    19 Jan 2011
    Link to this post
    I really have no idea what you are asking me to do.
    I thought this is a service where I log in, update my text, then it publishes using the Telerik service.
    This is a first time event, so are you asking me to hire a programmer to do something?
    It feels along the lines of me having a problem uploading a file to FaceBook, then FaceBook asking me to research my systems.
    I must be missing something here.
    Brian
  11. Brian Javeline
    Brian Javeline avatar
    12 posts
    Registered:
    11 Dec 2009
    02 Feb 2011
    Link to this post
    Hello,
    I am still having problems, no matter what I do, including creating a new page with regular text.
     
    Is there any way you can send me a direct email so we can communicate outside this forum since I am rather paralyzed at the moment and literally have been trying everything under the sun.  There is a problem at Telerik that i just can not see and perhaps I just give you access to my account becuase you can just keep sending me suggestions, but there is nothing else I can do at this point.

    Thanking you in advance.
    Brian Javeline
  12. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    03 Feb 2011
    Link to this post
    Hello Brian,

    The support system is based on forums and support requests. I will forward you request to one of our solution consultants and he will contact you.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  13. Brian Javeline
    Brian Javeline avatar
    12 posts
    Registered:
    11 Dec 2009
    03 Feb 2011
    Link to this post
    Please also add this new piece of information that I was able to figure out.
    I enter information and save it.
    I then go to Publish it and get an error.
    I then close out the browser session and for some reason the actual change does in deed take place.
    I then log back in and repeat this process.
    So for now I have figured out a strange way to get around the Publish process that causes an error.
    Thank you for your replies.
    Brian
  14. Arichandran
    Arichandran avatar
    2 posts
    Registered:
    12 Aug 2012
    12 Aug 2012
    Link to this post
    please include tamil language translation
  15. Arichandran
    Arichandran avatar
    2 posts
    Registered:
    12 Aug 2012
    12 Aug 2012
    Link to this post
    i am unable to do this
Register for webinar
15 posts, 0 answered