+1-888-365-2779
Try Now
More in this section

Forums / General Discussions / Slow Speed

Slow Speed

15 posts, 0 answered
  1. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    25 Mar 2010
    Link to this post
    Hi

    i am running sitefinity and it is running very slow every page load is v.slow . is is taking 7 -8 mins to start. after it starts or initilize site loads quickly.

    i hav not installed any 3rd party control.


    and i hav uploaded th precomplied version of the sitefinity.

    now plz tell what all i can do to test where is the performance cut
    the server and my isp bandwidth and speed is fine.


    check simsdelhi dot com


  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    25 Mar 2010
    Link to this post
    Hi vinamra,

    Check whether your application pool is not initialized when you make the first request. IIS, by default, will put an application to sleep if its unused for about 20 minutes.
    The website could load slowly on the first request if no one has made requests to your website and the application pool is being recycled which consume some time. To release some memory the worker process goes down and its is initialized right after recycling. Check whether <compilation debug="false"> in the web.config.

    You could increase the Idle-Time-out and Regular time for the application pool recycling from your SERVER >> Application Pools >> Advanced settings.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    25 Mar 2010
    Link to this post
    Hi

    this site is hosted on the shared  hosting of ixwebhosting so these details are not available to me

    but

    this slow down is happening always not only on first request.and  even in the admin panel

    like i am editing the page in admin panel and saves the page it take more than 10 mins


    is there any counters that i can place it coding and check is his problem due to server performance or sqlserver is taking time.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    25 Mar 2010
    Link to this post
    Hi vinamra,

    You can use HttpWatch, Fiddler and SQL Profiler to observe the requests. You should better set up the website on a local server and see how it will behaves. You could take a look at our demo  to see the pages and content performance  - http://demo.sitefinity.com/Home.aspx

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    25 Mar 2010
    Link to this post
    hi

    on localhost it iw working like charm.


    any example ho to use httpwatch, Fiddler with sitefinity


    Thanks
  6. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    25 Mar 2010
    Link to this post
    hi

    any solution its taking 10 min to initilize .

    plz help

    i hav also tested other cms and they r working perfectly

    i am on shared hosting and website is running in dedicated app pool

    plz suggest any solution

    Thanks
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    25 Mar 2010
    Link to this post
    Hello vinamra,

    Since the website is working properly on your local host, the problem is somewhere in the server where the website is currenlty hosted. Please use the above suggested ways to narrow down the issue.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  8. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    26 Mar 2010
    Link to this post
    hi

    i am attaching my error log file may be due to some error it is showing error
  9. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    26 Mar 2010
    Link to this post
    Hello vinamra,

    Thank you for providing the log file.
    There are some serious things in the configuration, and some manual operations performed by someone in the database are causing problems now. 
    Padding is invalid : The question is covered here - http://stackoverflow.com/questions/309859/padding-is-invalid-and-cannot-be-removed-exception-on-webresource-axd 
    We will give you a hint:
    The error is because your appdomain was recycled/restarted. When that happens the application and the machine key is set to auto, it changes. That affects the decryption of the info in the url of the resources urls (.axd). Setting up a fixed machine key will prevent it from ever happening again. 

    Could you please ensure that there is enough memory for the application pool, and the server is actually configured?

    There are missing stored procedures in the database. If you have a backup before the manual operations performed on the database, please restore it. Otherwise you may try to transfer the database as well, or perform upgrade/downgrade to another version of the CMS, so the database integrity could be restored. 

    Kind regards,
    Georgi
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  10. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    26 Mar 2010
    Link to this post
    hi

    i hav configured the mac key in my web.config

    and the missing stored proc error is occured when i was transfering my db and i visited my website.

    i hav talked to hosting company they r saying that we hav plenty of ram free.

    still slow performance. taking 10 mins to respond

    i think database is responding slow any counters i can place to check is it database or some thing else.
    because it take time to respond not to download the page. so i think it should be db .


    ok one thing more my app pool(dedicated) recycles every 20 min. so inmemory cache goes out.
    so if i do database cache then after 20 min when my app pool recycles and new/first request comes then what happen will it take same time.

     will it fills the memory/app pool with data/files and  then reads the cache from database

    or

    it skips out the memory filling and reads database cache and responds.

    how to do database cache. any example.

    Thanks
  11. raquel solis
    raquel solis avatar
    16 posts
    Registered:
    25 Mar 2010
    26 Mar 2010
    Link to this post
    hi! i have kind of the same problem... i was running sitefinity without trouble but then it started to get slow and this error appeard:

    Request timed out.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Request timed out.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): Request timed out.]

    i hope someone can help me please!! thanks a lot!
  12. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    28 Mar 2010
    Link to this post
    hi

    i tried to attach sql profiler to my database to check it is database performance issue but i am not allowed to attach my profiler.

    any other way i can check it is db performance issue or any thing else,

    can i add any counters in coding from which i can check it is db problem or any thing else
  13. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    28 Mar 2010
    Link to this post
    Hello vinamra,

    You could try to switch the host, it seems that the problem comes from the environment where you have hosted the website. Since you are not able to perform any tracing using SQL Profiler or another tool it is better to work in environment where you could use these tools.  The problem you have is not related to Sitefinity itself. Websites like www.teleril.com, www.sitefinity.com, blogs.telerik.com, sitefinitywatch.com, demo.sitefinity.com are entirely based on Sitefinity. As you can see although the high traffic, these websites does not have your problem.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  14. vinamra
    vinamra avatar
    45 posts
    Registered:
    23 Oct 2012
    28 Mar 2010
    Link to this post
    hi

    i am talking to the hosting company and the problem is from there side only. i am trying to get the app pool crash  error logs. once i get to know the exact problem i will post it.

    this problem is not related to sitefinity

    Thanks


  15. Ahmed Salman
    Ahmed Salman avatar
    31 posts
    Registered:
    13 Apr 2010
    22 Apr 2010
    Link to this post
    i have the same issue  "Exception Details: System.Web.HttpException: Request timed out."

    on i try to setup sitefinity on my local machine , and i am using discountasp.net SQL2008  ??

    any one can help me with this issue ?
Register for webinar
15 posts, 0 answered