+1-888-365-2779
Try Now
More in this section

Forums / Migrating from 3.x to the latest Sitefinity version / Migration tool fails to install with no explanation

Migration tool fails to install with no explanation

8 posts, 0 answered
  1. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    21 Dec 2011
    Link to this post
    I posted this yesterday, but my thread is gone, so I'm posting again.

    Using the project manager to set up my Sitefinity 3.7 SP4 project for migration gives a message that the installation failed, but no explanation why. The Project manager's log file doesn't list any errors. I can verify the DLL and SVC files coped over to the correct locations.

    I followed the manual migration guide, but then Sitefinity gave me an error that it could not connect to my 3.7 SP4 instance. The instance works fine from a browser.

    Would you give me some guidance on what I could try differently?

    Thanks!
  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    21 Dec 2011
    Link to this post
    is the file system location for the 3.7 website the same as the sf4 website you're migrating into? that is, it's not on a network share or something on a different machine?

    is it also setup in IIS? when you say the instance works fine from a browser, do you mean that you can access the ~/MigrationService.svc path on the 3.7 website?
  3. Dawn
    Dawn avatar
    37 posts
    Registered:
    17 Sep 2012
    22 Dec 2011
    Link to this post
    This happened to me too. Not sure what it is tho. 
  4. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    22 Dec 2011
    Link to this post
    Hi Josh,

    That's correct. Both sited are located on the same drive of the same machine. Additionally, both sites are navigable from the browser.

    As far as ~/MigrationService.svc goes, I got this exception:

    Exception!

    System.Configuration.ConfigurationErrorsException: Unrecognized attribute 'multipleSiteBindingsEnabled'. Note that attribute names are case-sensitive. (C:\webs\www.connectionsacademy.com\2009\web.config line 285) 
    at System.Configuration.BaseConfigurationRecord.EvaluateOne(String[] keys, SectionInput input, Boolean isTrusted, FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult) 
    at System.Configuration.BaseConfigurationRecord.Evaluate(FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult, Boolean getLkg, Boolean getRuntimeObject, Object& result, Object& resultRuntimeObject) 
    at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject) 
    at System.Configuration.BaseConfigurationRecord.GetSection(String configKey) 
    at System.Web.HttpContext.GetSection(String sectionName) 
    at System.Web.Configuration.HttpConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String configKey) 
    at System.Configuration.ConfigurationManager.GetSection(String sectionName) 
    at System.ServiceModel.Configuration.ConfigurationHelpers.UnsafeGetSectionFromConfigurationManager(String sectionPath) 
    at System.ServiceModel.Configuration.ConfigurationHelpers.UnsafeGetAssociatedSection(ContextInformation evalContext, String sectionPath) 
    at System.ServiceModel.Configuration.ServiceHostingEnvironmentSection.UnsafeGetSection() 
    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.LoadConfigParameters() 
    at System.ServiceModel.ServiceHostingEnvironment.HostingManager..ctor() 
    at System.ServiceModel.ServiceHostingEnvironment.EnsureInitialized() 
    at System.ServiceModel.PartialTrustHelpers.PartialTrustInvoke(ContextCallback callback, Object state) 
    at System.ServiceModel.Activation.HttpModule.ProcessRequest(Object sender, EventArgs e) 
    at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() 
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


    I was sure to use the 
    Module3.7_SP4_NET35.zip file, and edited web.config as explained on its Installation.txt file. Apparently this is because the provided zip file, for .net 3.5, contains web.config edits specific to .net 4.0. "multipleSiteBindingsEnabled" only exists in .net 4.0.
  5. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    22 Dec 2011
    Link to this post
    [removed by user]
  6. Dawn
    Dawn avatar
    37 posts
    Registered:
    17 Sep 2012
    22 Dec 2011
    Link to this post
    If you figure this out. I hope you can post it here. I am watching this post carefully. I am having the same problem. If I figure anything out I will post here too. 
  7. Connections Academy Developer
    Connections Academy Developer avatar
    151 posts
    Registered:
    04 May 2005
    02 Jan 2012
    Link to this post
    Update:

    Today I downloaded Sitefinity 4.4 and started fresh. The connection was successful, so I can move forward with the migration attempt.

    1. Complete a fresh install of 4.4.2117.0

    2. Copy MigrationService.svc to the root of the web site from Module3.7_SP4_NET35.zip

    3. Copy Telerik.Sitefinity.Migration.dll and Telerik.Sitefinity.MigrationContracts.dll to the /bin folder of the web site from Module3.7_SP4_NET35.zip

    4. Edit the web.config and add the following before the last </configuration> tag:

      <system.serviceModel>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true">
        </serviceHostingEnvironment>    
      </system.serviceModel>

    5. Rebuild 3.7 project. 

    6. Use 4.4 Project manager to set the 3.7 project for migration (succeeded!)
      
    7. Navigate to the /Sitefinity/Administration/Migration folder of the 4.4 site. 

    8. Enter 3.7 URL, admin username and PW, and click "Test connection"

    9. Get message: Connection has been successfully established
  8. Stanislav Velikov
    Stanislav Velikov avatar
    1113 posts
    Registered:
    06 Dec 2016
    04 Jan 2012
    Link to this post
    Hello,

    The approach mentioned by Connections Academy Developer is correct, however the same can be achieved without adding the service file, Telerik.Sitefinity.MigrationContracts.dll and the modification to web.config if you are using the automatic migration from Sitefinity 4.4 project manager because it adds all necessary files and modifies the web.config autmatically.  

    Greetings,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
8 posts, 0 answered