Try Now
More in this section

Forums / Migrating from 3.x to the latest Sitefinity version / SF 4/5 replacements for common SF 3.7 patterns

SF 4/5 replacements for common SF 3.7 patterns

1 posts, 0 answered
  1. Mike
    Mike avatar
    208 posts
    10 Dec 2007
    10 Apr 2012
    Link to this post
    One of the things that would really help the painful process of migration from SF 3.7 to SF 4/5 is some sort of guide to changing common coding patterns from SF 3.x to SF 4/5. 

    For example, I really need to know how to replace this (from a SF 3.7 site):
    <%@ Register Assembly="Telerik.Cms.Web.UI" Namespace="Telerik.Cms.Web.UI" TagPrefix="sfWeb" %>
    <sfWeb:CssFileLink ID="CssFileLink2" FileName="~/Styles/jquery.fancybox-1.3.4.css" Media="screen" runat="server" />
    <sfWeb:CssFileLink ID="CssFileLink1" FileName="~/Styles/SplashBoxStylesheet.css" Media="screen" runat="server" />

    with it's SF 4/5 equivalent. This can't be hard, but an extensive search of your site and the sparse documentation doesn't reveal much in the way of meanigful clues.  I'd also like to do this with javascript links.
    <sfWeb:JsFileLink ID="FacebookWallScriptLink" runat="server" FileName="~/Scripts/jquery.neosmart.fb.wall.js" />

    Also you seem to take a lot for granted...For example, in one place you tell us the skins and themes are embedded in Telerik.Web.UI.Skins.dll but how do I construct a resource link to these?? 

    Even if I copy the skin themes from the rad controls installation folders to my SF website, I can't seem to construct a simple link to them.  If I use something like this as is shown in several places on your site:
    <sf:ResourceLinks id="resourcesLinks" runat="server" Theme="Default16" UseEmbeddedThemes="false">
    <sf:ResourceFile Name="Css/window.css" />
    <sf:ResourceFile Name="Css/Window.Office2010Silver.css" />

    then Sitefinity constructs a link to /SFPageService/Css/window.css, which doesn't seem to exist. I've created a Css subfolder under my themes folder, and tried to link to those (supposedly the resource file is automatically mappeed to the current theme), but haven't been able to get that working either.

    I've posted a question about this in the bugs/issues forum nearly a week ago with no response (I posted in that forum because your theme seems to have several margin bugs). 

1 posts, 0 answered