+1-888-365-2779
Try Now
More in this section

Forums / Project Feather / Can't get feather mvc widget to show up in sitefinity toolbox

Can't get feather mvc widget to show up in sitefinity toolbox

5 posts, 3 answered
  1. Michael
    Michael avatar
    8 posts
    Registered:
    11 Jan 2011
    20 Feb
    Link to this post

    I am having just the worst time getting a new feather widget to register in the sitefinity toolbox.

     

    I took the sample ListWidget project and modified it just slightly, so that the list items have two properties instead of one... The list needs to be a list of hyperlinks instead of just strings.  So the list items are now objects with a string property for link text and a string property for url.  I'm pretty sure I've done that correctly, but I can't even check because I can't get the widget to show up in the toolbox.

    I haven't found a lot of info online about this problem, but I did see this thread:

    http://www.sitefinity.com/developer-network/forums/bugs-issues-/mvc-widgets-not-registering-in-sitefinity-using-feather

     

    And I've double checked everything in Velizar Bishurov's post which needs to be right before it will work.  I've also tried just compiling the sample list widget from the feather samples and referencing that dll, but that doesn't show up in the toolbox either, which makes me wonder if it's a problem with the sitefinity project and not with my widget project?

    I'm about at wits end here, and I'd really appreciate any help anyone can offer. 

     

    Here's a link to a zip archive of the widget project...

    https://www.dropbox.com/s/m590uaky78c0i0x/ListWidget.zip?dl=0

    Thanks...

     

    -Mike

    Answered
  2. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    22 Feb
    Link to this post
    Hello Mike,

    The widget is registering correctly on my end. I just referenced the project from the Sitefinity Web App and build it.
    Please, check whether the ToolboxesConfig has updated. There should be this record:
    <add enabled="True" title="Visus" ordinal="0" name="Visus">
                        <tools>
                            <add enabled="True" type="Telerik.Sitefinity.Mvc.Proxy.MvcControllerProxy" controllerType="ListWidget.MVC.Controllers.ListController" title="Related Links" ControllerName="ListWidget.MVC.Controllers.ListController" visibilityMode="None" name="Related Links" />
                        </tools>
                    </add>

    Please, let me know if you have any logic in the Global Application class.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
    Answered
  3. Michael
    Michael avatar
    8 posts
    Registered:
    11 Jan 2011
    22 Feb in reply to Nikola Zagorchev
    Link to this post

    Hi Nikola.

    I confirmed that the ToolBoxConfig file is not updating to include my widget.  If I add the lines you included above, the widget then shows up in the tooldbox, however, when I add that widget to a page, it doesn't pick up my custom designer from the widget assembly.  I'm wondering if there's something about the main sitefinity project which might be preventing feather from working properly?  I'm thinking the two issues are related somehow.

    Thanks so much for your reply,

    -Mike

  4. Michael
    Michael avatar
    8 posts
    Registered:
    11 Jan 2011
    22 Feb
    Link to this post

    I was able to resolve this issue after thinking more about what I've seen and what Nikola said.  Turns out the issue was that I did not have the feather module installed/enabled in Sitefinity (I just didn't know about it).  After looking through some of the more general getting started guides for feather, I noticed it mentioned and went looking for it.

     

    Once that was done, it started showing up in the toolbox like it should.  I did have an issue with the 'no parameterless constructor defined for this object', but I found a document talking about that specific issue with a resolution which worked for me, so now everything is grand.

    Thanks,

    -Mike

    Answered
  5. Nikola Zagorchev
    Nikola Zagorchev avatar
    424 posts
    Registered:
    24 Nov 2016
    25 Feb
    Link to this post
    Hi Mike,

    Thank you for letting us know.

    The Feather module should be active. It will be automatically activated in Sitefinity 9.0.
    Let us know whether we can assist further.

    Regards,
    Nikola Zagorchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
5 posts, 3 answered