+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Installation problem

Installation problem

5 posts, 0 answered
  1. Drew Reutlinger
    Drew Reutlinger avatar
    17 posts
    Registered:
    25 Sep 2009
    14 Jan 2010
    Link to this post
    I have installed Sitefinity 3.7 on a Windows Server 2003 machine running IIS6. I installed it using the .exe installer. It finishes the installation successfully and everything seems to be set up correctly. However, when I attempt to browse to any aspx page afterwards, I get "Page not Found" error.

    I've checked the permissions and everything seems to have been set up correctly. Is there a configuration setting that I may have missed?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    14 Jan 2010
    Link to this post
    Hello Drew Reutlinger,

    Please check whether you have ASP.NET installed and make sure that you have handler mapping for .aspx.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Drew Reutlinger
    Drew Reutlinger avatar
    17 posts
    Registered:
    25 Sep 2009
    14 Jan 2010
    Link to this post
    Wow, thanks for the speedy response (one reason I love Telerik).

    I do have ASP.NET installed on the server. I have the version set to 2.0.50727. Ok, I found where the handler mappings are and they are configured correctly.
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    14 Jan 2010
    Link to this post
    Hi Drew Reutlinger,

    If you are talking from he project manager of Sitefinity, it seems that the  application is prevented from running on your Web Server.You can check whether IIS is allowed  to serve dynamic content:
    1. Open IIS, expand the master server node (that is the Servername node), and then select the Web Service Extensions node.
    2. In the right pane, right-click ASP.NET v2.0.50727.
    3. Click Allow.
    You may also find the following kb article useful - HTTP Error 404 - File or Directory not found

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Drew Reutlinger
    Drew Reutlinger avatar
    17 posts
    Registered:
    25 Sep 2009
    14 Jan 2010
    Link to this post
    On the server in question, I had an inclination that the .NET framework had been installed before IIS. I un-installed all the .NET frameworks and also IIS. I did a reboot, installed IIS first, then the .NET 3.5 Framework Family. After the auto-install of Sitefinity, I now have success.

    Thanks for the help, but it looks like the server had been the issue the whole time.
Register for webinar
5 posts, 0 answered