+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / 401 Unauthorized

401 Unauthorized

9 posts, 0 answered
  1. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    05 May 2009
    Link to this post
    Hi,

    We're trying to install the Standard edition on our local machine and getting nothing in IE7.0 when we try to browse to the project manager.

    The configuration is as follows:
    Sitefinity 3.6 Standard Edition
    Windows XP
    IE  7

    The browser itself doesn't show any errors, but if you look at the IIS logs you get the following:
    10:20:33 127.0.0.1 GET /telerik/sitefinity3.6 401

    Normally 401 means unauthorized access.

    We checked your troubleshooting section and found the 401.2 section which suggests:
    1. Anonymous Authentication is disabled.
    2. ASP.NET Impersonation is enabled.
    3. Forms Authentication is disabled.
    4. Windows Authentication is enabled.

    Anonymous for us is disabled as is forms authentication since in the web.config the authentication mode is set to windows. But how do you configure the Asp.net Impersonation?

    Other than that we've tried everything from providing the correct permissions on folders and so forth.

    The installation seems to work fine on other machines, but not this one.

    What else should we be looking at?

    Thanks Jacques
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    05 May 2009
    Link to this post
    Hi J.Hov,

    You can take a look at http://www.sitefinitywatch.com/blog.aspx where Gabe has created several posts about Sitefinity installations.
    As for enabling and disabling ASP.NET Impersonation you can check MSDN. By default we use Forms authentication which is set in the web.config.

    Greetings,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    05 May 2009
    Link to this post
    Hi Ivan,

    If you look at my post you'll notice that I've actually copied content from your Troubleshooting page which says you do not use Forms authentication.

    I've tried manually configuring the web.config file to include the impersonation settings to no avail. It still does the exact same thing. We added the impersonate setting to the web.config file.

    As mentioned in my post I'm referring specifically to the Project Manager. Are you saying that Forms authentication should in fact be enabled?

    Regards,
    Jacques
  4. Gabe Sumner
    Gabe Sumner avatar
    440 posts
    Registered:
    09 Sep 2007
    06 May 2009
    Link to this post
    Hey Jacques,

    Check to make sure that the telerik\Sitefinity3.6 web application in IIS is using the Classic .NET AppPool for the Application Pool.  Also, make sure you're running IE as Administrator. 

    I also created a video on this subject.  It might help give some ideas as well:

    http://www.sitefinitywatch.com/blog/09-05-04/Bullet_Proof_Guide_to_Installing_Sitefinity_3_x.aspx

    Let me know if this doesn't help.

    Gabe Sumner
    http://www.sitefinitywatch.com/
  5. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    07 May 2009
    Link to this post
    Guys, I've seen someone write about this before on your site. Most of the information and video clips you're giving are for Vista not XP. I don't know that the IIS version on XP allows you to choose App Pools.

    Can we maybe get some solutions for this problem, but for XP?

    Regards,
    Jacques
  6. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    08 May 2009
    Link to this post
    We've still not been able to sort out this problem with WindowsXP, can you provide us with your troubleshooting steps but for WindowsXP please?

    Regards,
    Jacques
  7. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    11 May 2009
    Link to this post
    Hi J.Hov,

    Could you please enable Anonymous Authentication? For some reason the account under which you are running could not be authenticated. The reason for this hides somewhere in the server configuration.

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  8. Jacques
    Jacques avatar
    427 posts
    Registered:
    28 Jun 2007
    11 May 2009
    Link to this post
    We have finally managed to solve the problem and only after we uninstalled all the .net framework versions, SQL 2005 Express, Visual Web Developer, followed up by using a cleanup tool to fully remove these components.

    We then set about installing everything again in the following order:
    * .net Framework 2.0
    * SQL 2005 Express (which gave problems with MSXML 6.0 for which we used the cleaning tool, and that fixed the SQL installation)
    * SQL 2005 Express Management Studio
    * Sitefinity 3.6
    * Visual Web Developer

    Now everything seems to be sorted out and working as it should.

    Regards,
    Jacques
  9. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    11 May 2009
    Link to this post
    Hi J.Hov,

    I am glad you have managed to get the things running as expected, but regret that we did not found the root of the problem.

    Don't hesitate to contact us if you have other questions.

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Register for webinar
9 posts, 0 answered