+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Access to the path 'TIUSite_v3.5_SP1' is denied

Access to the path 'TIUSite_v3.5_SP1' is denied

4 posts, 0 answered
  1. Geoffrey
    Geoffrey avatar
    4 posts
    Registered:
    02 Apr 2008
    15 Nov 2008
    Link to this post

    Can anyone give me an idea what I am doing wrong? I have Vista Ultimate running on my pc.

    Here is what I've done:
    1) Configured IIS per Installationn doc "Installing Sitefinity under Windows® Vista"
    2) Installed Sitefinity 3.5 Community Edition 
    3) In IIS Manager I granted IUSR and the my user account full control to the Sitefinity3.5 Community virtual folder. Network Service already has full control. I don't see an ASPNET account.

    When I run the project manager, I am prompted to login. I  successfully supply my Vista credentials. However when I clcik on Explore Sample site, I again am prompted to login. I again supply my Vista credentials but it fails. On the third attempt, I get following error:

    Access to the path 'TIUSite_v3.5_SP1' is denied

    ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

    Thanks
    Geoffrey Wade
  2. Geoffrey
    Geoffrey avatar
    4 posts
    Registered:
    02 Apr 2008
    15 Nov 2008
    Link to this post

    I found the following post.
    http://www.sitefinity.com/support/forums/support-forum-thread/b1043S-becedh.aspx

    Stefan was having the same problem as I am.



    Pepi from the Telerik team wrote:

    This error can be caused by the following:
    • The user, with which you are logging in, does not impersonate to an existing windows account. Make sure that Integrated Windows Authentication is enabled and Anonymous access is selected for the Sitefinity3.2 virtual directory in the IIS.
    • The windows account, to which the user is impersonated, has no rights to create virtual directories. Could you set up virtual directories under IIS manually?
    Do let us know if you need any further assistance.



    In IIS manager I have the authentication settings for the Sitefinity3.5 Community virtual directory;

    Anonymous Authentication  Disabled
    ASP.NET Impersonation  Enabled
    Forms Authentication    Disabled
    Windows Authentication    Enabled

    which is according to the UserManual
    1.Anonymous Authentication is disabled.
    2.ASP.NET Impersonatiion enabled.
    3.Forms Authentication is disabled.
    4.Windows Authentication is enabled.

    I even tried enabling Anonymous Authentication as Pepi suggested but that didn't work either.

    Any suggestions?
  3. Geoffrey
    Geoffrey avatar
    4 posts
    Registered:
    02 Apr 2008
    17 Nov 2008
    Link to this post
    This thread is closed.
  4. Geoffrey
    Geoffrey avatar
    4 posts
    Registered:
    02 Apr 2008
    17 Nov 2008
    Link to this post
    This thread is closed.
Register for webinar
4 posts, 0 answered