+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Installation problem

Installation problem

12 posts, 0 answered
  1. Mona
    Mona avatar
    2 posts
    Registered:
    12 Apr 2008
    24 Jun 2008
    Link to this post

    Hello;

    I am trying to install sitefinity 3.2 on windows server 2003 and i got the following error during installation

    "Error 1001: InstallUtilLib.dll: unknown error" then the installation roll back after clicking ok button for the error message.

    Could any one help me with this error?!
  2. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    24 Jun 2008
    Link to this post
    Hello Mona,

    Thank you for your interest in Sitefinity and contacting us. We are sorry to hear you're having problems installing our CMS.
    Do you have .NET 2.0 installed on your computer? Also, make sure ASP.NET is registered in IIS by the C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe utility.
    Maybe this is the reason for the problem.

    Another thing you can try is uninstall Sitefinity using the Windows Installer Cleanup Utility that is offered by Microsoft. Make sure that no files and folders remain in the installation folder and that all system requirements are met. You can check them out here:
    Installation Guide
    Then you can proceed with the new installation and get back to
    us if you get the error again. It would be great if you could give us more details, such as:
    1. OS and exact version.
    2. Security software and whether it was deactivated at the time of the installation.
    3. Was the installation completed anyway.

    Looking forward to your reply,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Mona
    Mona avatar
    2 posts
    Registered:
    12 Apr 2008
    25 Jun 2008
    Link to this post
    Is .Net framework 2.0 only enough ?!
  4. Rebecca
    Rebecca avatar
    536 posts
    Registered:
    24 Sep 2012
    25 Jun 2008
    Link to this post
    Hello Mona,

    Please check if all system requirements are met here:

    Installation Guide

    Best wishes,
    Rebecca
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Code
    Code avatar
    3 posts
    Registered:
    26 Nov 2010
    29 Nov 2010
    Link to this post
    Hi,

    Yet, No Solution Found
  6. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    29 Nov 2010
    Link to this post
    Hi Code,

    Since this is over two years old post, could you tell me what the problem is?

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Code
    Code avatar
    3 posts
    Registered:
    26 Nov 2010
    29 Nov 2010
    Link to this post
    Hi,

     I will describe you all the details here;
    Environment - Windows 7, VS-2008, SqlServer 2005, IIS 7
    we downloaded Sitefinity_3_7_2136_standard_trial from your website
    We are trying to install this CMS setup but getting error in set up -
    "Error-1001 InstallUtilLib.dll Unknown error"
    We tried to find out the solution but all in vain.
    Please suggest us the solution as soon as possible
  8. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    29 Nov 2010
    Link to this post
    Hi Code,

    Thank you for the clarification.

    This is a bug with the installer of the latest official release of Sitefinity 3.7. The problem can be worked around if you download the installer for Sitefinity 3.7 SP3 (the previous release) and install it. Then use the latest version (3.7.2136 the one you have initially downloaded) and install it over the first installation.

    Best wishes,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. Code
    Code avatar
    3 posts
    Registered:
    26 Nov 2010
    29 Nov 2010
    Link to this post
    Hi,

    Thanks a lot to explain us the solution, because we were facing this problem for last 2 days and trying to resolve it,
    So this is my suggestion to Telerik that It's common problem we are facing with 3.7 SP4 version so It should be mention somewhere on the website or generate the patch for it . It would be beneficial to users in finding the solution for this problem.
  10. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    29 Nov 2010
    Link to this post
    Hello Code,

    If you get the same error after following Rado's suggestion, you can try using Blank project

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Cii
    Cii avatar
    10 posts
    Registered:
    13 Jan 2011
    01 Mar 2011
    Link to this post
    Hi,

    I do not know if you are still interested but, in one of the forums (related to this one) you told that you were unable to recreate the error 1001 problem: here is a guarantied error recreation method:

    * format a computer with windows 7 ultimate N 32-bit (I used a virtual computer with VmWare)
    * install windows IIS components (like in your installation guide)
    * install Visual Studio .NET 2008 (excluding MSSQL 2005 options)
    * install Visual Studio .NET 2008 Service Pack 1
    * install MSSQL Express 8
    * update all products using windows update (exclude for .NET framework 4.0 for clients)
    * install Sitefinity 3.7 SP4 (not SP3)

    above steps lead to error 1001... when I tried the same with SP3, I was able to install the sitefinity.

    Just wanted to let you know...
    Cihan
  12. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    01 Mar 2011
    Link to this post
    Hello Cii,

    OK, we will verify these steps for the next SP.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
Register for webinar
12 posts, 0 answered