+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Issue with localization

Issue with localization

3 posts, 0 answered
  1. Kiearn
    Kiearn avatar
    6 posts
    Registered:
    07 Aug 2008
    22 May 2009
    Link to this post
    Hi

    I'm using version 3.6, I have set up sitefinity with multiple languages but I am having a problem adding Irish as "ga" is not supported.

    I've tried ga-IE but causes Invariant Language

    Any idea is this possible???


    <localization defaultProvider="Sitefinity" persistenceMode="PathPrefix" defaultCulture="en" cultures="en, de, es, ga">  
          <providers>  
            <clear/>  
            <add name="Sitefinity" type="Telerik.Localization.Data.DefaultProvider, Telerik.Localization.Data" connectionStringName="DefaultConnection"/>  
          </providers>  
        </localization> 


    Thanks
    Kieran
  2. Nikolai
    Nikolai avatar
    216 posts
    Registered:
    21 Nov 2016
    25 May 2009
    Link to this post
    Hi Kiearn,

    First you should enable the specific cultures by adding "allowSpecificCultures="true"" attribute. I have checked the msdn CultureInfo Class and according to the info there the English - Ireland culture code is "en-IE".
     
    Localization node of your web.config file should be configured as below:

    <localization defaultProvider="Sitefinity" allowSpecificCultures="true" persistenceMode="QueryString" defaultCulture="en" cultures="en, es, fr, de, bg, en-IE"

    When you start Sitefinity the English(Eire) culture should be present in the Language bar.

    Sincerely yours,
    Nikolai
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Kiearn
    Kiearn avatar
    6 posts
    Registered:
    07 Aug 2008
    25 May 2009
    Link to this post
    Thank you Nikolai,

    I was able to work with that and get the Irish Language working also.

     

    <localization defaultProvider="Sitefinity" persistenceMode="PathPrefix" allowSpecificCultures="true" defaultCulture="en-IE" cultures="en-IE, ga-IE"
          <providers> 
            <clear/> 
            <add name="Sitefinity" type="Telerik.Localization.Data.DefaultProvider, Telerik.Localization.Data" connectionStringName="DefaultConnection"/> 
          </providers> 
        </localization> 

Register for webinar
3 posts, 0 answered