+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / machine.config source error 3.2 Community Edition

machine.config source error 3.2 Community Edition

6 posts, 0 answered
  1. a. simon mielniczuk
    a. simon mielniczuk avatar
    4 posts
    Registered:
    26 Jul 2005
    02 Jun 2008
    Link to this post
    Any thoughts on why 3.2 Community edition produces the following error when first attempting to start the application?

    Parser Error Message: The connection name 'LocalSqlServer' was not found in the applications configuration or the connection string is empty.

    Source Error:

    Line 193:    <roleManager>
    Line 194:      <providers>
    Line 195:        <add name="AspNetSqlRoleProvider" connectionStringName="LocalSqlServer" applicationName="/" type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
    Line 196:        <add name="AspNetWindowsTokenRoleProvider" applicationName="/" type="System.Web.Security.WindowsTokenRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
    Line 197:      </providers>
  2. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    02 Jun 2008
    Link to this post
    try checking the "connectionstrings" node of the web.config file and make sure that the connection string name matches the one that the provider is looking for:

    <connectionStrings> 
        <add name="Sitefinity" connectionString="Data Source=.\SQLExpress;Integrated Security=True;User Instance=True;AttachDBFilename=|DataDirectory|Sitefinity.mdf" providerName="System.Data.SqlClient"/>  
      </connectionStrings> 

    in this case the connection string name is Sitefinity, so change LocalSqlServer to Sitefinity and you should be able to connect (assuming your connectionstring is valid)

    hope that was helpful!
  3. SelAromDotNet
    SelAromDotNet avatar
    912 posts
    Registered:
    18 Jul 2012
    02 Jun 2008
    Link to this post
    checked my web.config and mine is a bit different. if the above suggestion doesn't work, try looking for the nolics connection definition in the web.config file:

            <dataAccess defaultConnection="DefaultConnection">  
                <connections> 
                    <add name="DefaultConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2005Provider" connectionStringName="Sitefinity"/>  
                    <add name="GenericContentConnection" driver="Telerik.Cms.Engine.Data.Providers.GCSql2005Provider, Telerik.Cms.Engine.Data" connectionStringName="Sitefinity"/>  
                </connections> 
                <cacheDependency mode="InMemory"/>  
            </dataAccess> 

    in my case the roleprovider connectionStringName matches the DefaultConnection name, just make sure the connectionStringName of the DefaultConnection matches the main connectionstring (in this case Sitefinity)

    hope that wasn't confusing, i'm still learning all this stuff myself :)
  4. a. simon mielniczuk
    a. simon mielniczuk avatar
    4 posts
    Registered:
    26 Jul 2005
    02 Jun 2008
    Link to this post
    Thanks for the prompt reply. It is helpful, but doesn't yet solve the problme.

    The errror message reported earlier shows up in the machine.config file - not the web.config. The web.config file in the Sitefinity 3.2 ProjectManager directory (which the installer made the root dir of the web site) shows the following:

    <configuration> 
        <configSections> 
            <sectionGroup name="telerik">  
                <section name="projectManager" type="Telerik.Cms.ProjectManager.ProjectManagerSectionHandler, Telerik.Cms.ProjectManager" requirePermission="false" /> 
            </sectionGroup> 
        </configSections> 
        <appSettings /> 
        <connectionStrings /> 
        <system.web> 
            <compilation debug="true"></compilation> 
            <authentication mode="Windows" /> 
        </system.web> 
        <system.codedom> 
        </system.codedom> 
        <system.webServer> 
            <handlers> 
                <remove name="StaticFile" /> 
                <add name="StaticFile" path="*" verb="*" type="" modules="StaticFileModule,DefaultDocumentModule,DirectoryListingModule" scriptProcessor="" resourceType="Either" requireAccess="Read" preCondition="" /> 
            </handlers> 
        </system.webServer> 
        <telerik> 
            <projectManager> 
                <destinations> 
                </destinations> 
            </projectManager> 
        </telerik> 
    </configuration> 

    Does this match up with your installation, SelArom? Perhaps my original installation is flawed.

    Note to Telerik: I prefer to have 'manual' installation options on complex applications along with the automated wizards. This makes it easier to check each step in the event of unexpected behaviour.

  5. a. simon mielniczuk
    a. simon mielniczuk avatar
    4 posts
    Registered:
    26 Jul 2005
    04 Jun 2008
    Link to this post
    the local IIS7 server was missing a connectionString setting. Had to add:
    data source=.\SQLEXPVISTA;Integrated Security=SSPI;initial catalog=aspnetdb

    NOTE: the SQL Express instance has a different name. If trying the above, use .\SQLExpress if you haven't changed the default instance.
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    04 Jun 2008
    Link to this post
    Hi Simon,
    It's a bit strange your Project Manager web.config looks like that. Here's the original one, taken from Sitefinity 3.2 Community Edition:
    <?xml version="1.0"?> 
    <configuration> 
        <configSections> 
            <sectionGroup name="telerik"
                <section name="projectManager" type="Telerik.Cms.ProjectManager.ProjectManagerSectionHandler, Telerik.Cms.ProjectManager" requirePermission="false"/> 
            </sectionGroup> 
        </configSections> 
        <appSettings/> 
        <connectionStrings/> 
        <system.web> 
            <compilation debug="true"></compilation> 
            <authentication mode="Windows"/> 
        </system.web> 
        <system.codedom> 
        </system.codedom> 
        <system.webServer> 
        </system.webServer> 
        <telerik> 
            <projectManager> 
                <destinations> 
                </destinations> 
            </projectManager> 
        </telerik> 
    </configuration> 

    Please try using this one instead of yours (but backup yours first).

    About your note, there's a way to manually create a project, which might help you if the project manager is not working as expected. Simply use the project inside the EmptyProject.zip archive. You may refer to this entry in our online Troubleshooting Unable to create the virtual directory. Unknown name which is also covers this procedure.

    Best wishes,
    Georgi
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Register for webinar
6 posts, 0 answered