+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Shared hosting, IIS7 and MySQL

Shared hosting, IIS7 and MySQL

7 posts, 1 answered
  1. harlowhair
    harlowhair avatar
    12 posts
    Registered:
    21 Nov 2006
    23 Feb 2010
    Link to this post
    Hi,

    I'm trying to install Sitefinity on a shared hosting provider (heart internet) - I've been told that they run in Full Trust, and are using IIS7.

    I get the initial installation screen, select MySQL database and enter the details and click next.  At this point it searches for Administrators and I then get an error screen:

     

    Server Error in '/mobileshoppa.com' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-sfinity.NN_NextValue' at line 1

    Source Error:

    Line 104:        <clear />
    Line 105:        <add connectionStringName="DefaultConnection" applicationName="/"
    Line 106: name="Sitefinity" type="Telerik.DataAccess.AspnetProviders.TelerikRoleProvider, Telerik.DataAccess" />Line 107:      </providers>
    Line 108:    </roleManager>

    Source File: \\10.0.3.22\home\mobileshoppa.com\public_html\web.config    Line: 106


    Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016

    Is there any dependencies I am missing in order to use MySQL?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    23 Feb 2010
    Link to this post
    Hello harlowhair,

    This is a very strange error in the Sitefinity Startup Wizard. Most probably it is related to the database you use.
    Try to create a new project with a completely new database to see if you will get the same error. For instance try on a local server. Do not use any special chars in the name of the database or prefixes. Try with something simple like "test" Generally shared hosting providers set some permissions that could break the installation. There could be another hidden error thrown in the log file(App_data/Sitefinity.log) If you are using Project Manager you should be also an administrator with full rights of the server( and full permissions over the db - root user).   Please ensure that you have at least MySQL 5.1 installed on your machine. Nolics does not support versions prior 5.0.27.

    Best wishes,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. harlowhair
    harlowhair avatar
    12 posts
    Registered:
    21 Nov 2006
    24 Feb 2010
    Link to this post
    I have recreated this on a local install and the issue appears to be due to a hyphen in the database name (web237-sfinity).  I have tried a number of ways of working around this, including setting up a local install using a db name without a hyphen, and then copying everything across to a new db, however as soon as the hyphen is introduced it throws an error.

    I'm not sure if this is to do with how Nolics generates Sql as the db name needs to be surrounded with backticks - any ideas on how to solve this?
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    24 Feb 2010
    Link to this post
    Hello harlowhair,

    As suggested "Do not use any special chars in the name of the database or prefixes". I noticed this problem only with MySQL, but I do not believe that this is related to the nolics. The problem you are encountering is related to one of the stored procedures. Most probably MySQL makes something internally, but it  is better not to use any chars in the database name no matter what platform you are using.

    Kind regards,
    Ivan Dimitrov
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. harlowhair
    harlowhair avatar
    12 posts
    Registered:
    21 Nov 2006
    26 Feb 2010
    Link to this post
    Hi Ivan,

    The host I am using are refusing to change the name of the database as they have a strict naming convention.  I have searched through all stored procs and functions and everywhere that the DB name is used it is surrounded by backticks so should be fine.  Is there anywhere else that I could check?   I have also searchd the information schema for the phrase -sfinity.NN_NextValue and it isn't found which is what led me to believe it could be an issue with some dynamically generated sql.

    Thanks,
    Rob
  6. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    26 Feb 2010
    Link to this post
    Hi harlowhair,

    Thank you for getting back.

    We have been able to find a solution to the problem. You will have to upgrade the MySql.Data.dll in your Sitefinity project. This is the MySQL connector for .NET which the Nolics ORM uses. What you can do is to download the latest version of the connector from here: Download Connector/Net. Then what you have to do is to install the MySQL connector on a local machine, then go to install destination open Assemblies directory and copy the MySql.Data.dll to the bin folder of your project. This will replace the existing file there. Open the web.config file and perform a binding redirect to the new version of the assembly:
    <runtime>
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
        ...
        <dependentAssembly>
          <assemblyIdentity name="MySql.Data" publicKeyToken="c5687fc88969c44d"/>
          <bindingRedirect oldVersion="5.0.7.0" newVersion="6.2.2.0"/>
        </dependentAssembly>
      </assemblyBinding>
    </runtime>

    We recommend that you perform all those changes on a local environment because MySQL creates database objects very slowly and really makes a performance hit on CPU and memory while creating db objects in a blank database. Once you connect the database locally and it creates all tables and stored procedures you can just back it up and restore it on hosting provider's MySql server.

    Best wishes,
    Radoslav Georgiev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
    Answered
  7. harlowhair
    harlowhair avatar
    12 posts
    Registered:
    21 Nov 2006
    26 Feb 2010
    Link to this post
    Fantastic!  That solved my problem, and (after another couple of stumbling blocks) I have a working install of Sitefinity.

    Thanks a lot

    Rob
Register for webinar
7 posts, 1 answered