+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / TelerikMembershipProvider and requiresUniqueEmail

TelerikMembershipProvider and requiresUniqueEmail

9 posts, 1 answered
  1. alo
    alo avatar
    23 posts
    Registered:
    02 Jan 2009
    11 Dec 2010
    Link to this post
    After upgrading to Sitefinity 3.7 SP4, it appears that I can no longer register users when the requiresUniqueEmail attribute is set to "true".  I get the following error for any email address I attempt:

    The e-mail address that you entered is already in use. Please enter a different e-mail address.

    If I change the requiresUniqueEmail attribute to "false", the user is registered successfully. 

    Did I do something wrong in the upgrade to cause this problem?

    Thanks,

    Al 
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    11 Dec 2010
    Link to this post
    Hello alo,

    Please take a look at this post.

    Regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. alo
    alo avatar
    23 posts
    Registered:
    02 Jan 2009
    11 Dec 2010
    Link to this post
    It appears that this problem has occurred before as indicated in the referred post.  It's good to know that someone else is experiencing the same exact issue.

    The only resolution mentioned in that post was to revert back to SP3 and then reapply SP4.  Is that the official resolution?  That will be hard for me to do because I converted my project to .NET 4.0 and I'm not sure how going back to SP3 will work.

    Perhaps we could explore the root cause of this issue and offer a solution that does not require going back to SP3.

    Al 
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    11 Dec 2010
    Link to this post
    Hello alo,

    I did not suggest reverting back. As you can see the issue does not appear at our end. Can you tell me the version of Sitefinity you use - build version, so I will try on the same clean solution to replicate the issue again.

    How you are registering your users? From a control or using the backend? If it is a control which control us use?

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. alo
    alo avatar
    23 posts
    Registered:
    02 Jan 2009
    12 Dec 2010
    Link to this post
    The build version is 3.7.2136.240.

    I'm using the CreateUserWizardControl.  I've customized the control, but it worked fine prior to SP4.  It also works fine if requiresUniqueEmail = "false".

    Thanks for you help.

    Al
  6. alo
    alo avatar
    23 posts
    Registered:
    02 Jan 2009
    12 Dec 2010
    Link to this post
    I can confirm that the same problem exists adding a user using the Sitefinity Admin "Add User" page.  When requiresUniqueEmail = true I get the following error:

    The e-mail address that you entered is already in use. Please enter a different e-mail address.

    When requiresUniqueEmail  = false, it works fine.

    This is how the membership provider is set up in the web.config file:

    <membership defaultProvider="Sitefinity" userIsOnlineTimeWindow="15" hashAlgorithmType="">
        <providers>
            <clear/>
            <add name="Sitefinity" connectionStringName="DefaultConnection" type="Telerik.DataAccess.AspnetProviders.TelerikMembershipProvider, Telerik.DataAccess" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="true" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" passwordAttemptWindow="10" passwordStrengthRegularExpression="" minRequiredPasswordLength="1" minRequiredNonalphanumericCharacters="0"/>
        </providers>
    </membership>

    Something must have been corrupted when I did the upgrade.

    More info, I'm using SQL Server 2008, Windows 7 Ultimate 64-Bit, .NET 4.0, VS 2010.

    Al
  7. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    13 Dec 2010
    Link to this post
    Hi alo,

    I prepared a sample project that uses Sitefinity 3.7 SP4, build 2136 for .NET 4.0 and I was not able to replicate this issue.  I attached a project and short video. You can access the project by using "admin" as a username and password. If you can replicate the issue on this project it would be great, so I can check the code again.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. alo
    alo avatar
    23 posts
    Registered:
    02 Jan 2009
    14 Dec 2010
    Link to this post
    Your test project worked fine.  So, I compared the two projects and found one difference in the web.config file.  My web.config had the following:

    <add name="DefaultConnection" driver="Nolics.ORMapper.DataProviders.SqlServer2005Provider" connectionStringName="Sitefinity"/>

    and yours had:

    <add name="DefaultConnection" driver="Telerik.DataAccess.Providers.ExtendedSqlServer2005Provider, Telerik.DataAccess" connectionStringName="Sitefinity"/>

    If I use your setting, my process works correctly.  If I use mine in your test project, it shows the error.

    Anyway, I must have missed this change in the web.config file during one of the upgrades.  Thanks for helping fix this problem.

    Al
  9. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    14 Dec 2010
    Link to this post
    Hello alo,

    The correct data provider is ExtendedSqlServer2005Provider. It was implemented since Sitefinity 3.7.

    Best wishes,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
    Answered
Register for webinar
9 posts, 1 answered