+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Upgrade Sitefinity from 3.2 SP1 to 3.7 SP4

Upgrade Sitefinity from 3.2 SP1 to 3.7 SP4

4 posts, 0 answered
  1. Tariq
    Tariq avatar
    2 posts
    Registered:
    25 Sep 2010
    25 Oct 2010
    Link to this post
    Hi,

    I'm trying to get my head around getting an existing live website running Sitefinity 3.2 SP1 ported across to a new server running the latest version.  At this time I want to stage the site on a local machine.

    I've setup a new Windows XP machine, installed IIS and installed all the .NET frameworks plus all the patches, and installed MS SQL 2008 R2 Express.

    I assumed that the following would be the process:

    1)  Detach the database from the existing site and copy the files to the XP machine and reattach to SQL 2008 Express.
    2)  Install the FULL version of Sitefinity 3.2 SP1 on the XP Machine.
    3)  Do a full copy of the wwwroot directory from the server and copy over the top of the wwwroot folder of the XP machine.
    4)  Perform the upgrade from 3.2 SP1 to 3.7 SP4 according to the upgrade instructions.

    Am I on the right track here?
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    25 Nov 2016
    25 Oct 2010
    Link to this post
    Hello Tariq,

    You do not have to install the full version of Sitefinity. I suggest that you should check our upgrade instructions.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Tariq
    Tariq avatar
    2 posts
    Registered:
    25 Sep 2010
    25 Oct 2010
    Link to this post
    OK, thanks Ivan.

    So I have a clean installation and have copied over the wwwroot folder from the old site, and the http://localhost site is giving me the correct homepage and pretty much all of the links work correctly.

    I have not even started on the upgrade instructions yet - just trying to get the site replicated onto my local machine.

    So I'm facing the issue where all of my files and images are not being displayed - I'm getting a page not found error.  The URL reads: http://localhost/Libraries/Calendars/Calendar%202010-2011.sflb?download=true

    I'm trying to follow this procedure (http://www.sitefinity.com/sf3/troubleshooting.html#1) but I don't know what the previous virtual directory is!  Can you help?  Is there a command I can execute that will show me what the old virtual directory?

    Thanks,

    Tariq.
  4. Radoslav Georgiev
    Radoslav Georgiev avatar
    3370 posts
    Registered:
    01 Feb 2016
    26 Oct 2010
    Link to this post
    Hello Tariq,

    Thank you for getting back to us.

    It seems that the problem on your side is caused by how urls to items from Images and Documents were handled in 3.2. Mainly how the white space character is treated in the url to the item. You can take a look at this KB article for information on resolving this issue: How to replace urlWhitespaceChar in your Images and Documents library items after upgrade from 3.2 to 3.5.

    Sincerely yours,
    Radoslav Georgiev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Register for webinar
4 posts, 0 answered