+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / upgrading 3.6 to 3.7 error

upgrading 3.6 to 3.7 error

6 posts, 1 answered
  1. Andrew
    Andrew avatar
    202 posts
    Registered:
    05 Jun 2009
    20 Aug 2009
    Link to this post
    I have been following this: http://www.sitefinity.com/support/upgrade-instructions.aspx

    To upgrade my project from 3.6 to 3.6.

    At step seven. I get this error:

    Server Error in '/via_web' Application.  
    --------------------------------------------------------------------------------  
     
    Could not load file or assembly 'Telerik.Security, Version=3.6.1936.2, Culture=neutralPublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)   
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.   
     
    Exception Details: System.IO.FileLoadException: Could not load file or assembly 'Telerik.Security, Version=3.6.1936.2, Culture=neutralPublicKeyToken=dfeaee0e3978ac79' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)  
     
     


    Any idea what the problem is?

  2. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    20 Aug 2009
    Link to this post
    Hello Andrew,

    Most probably you haven't replaced all the dll files in the bin directory, or you have a custom module that is build with the old dlls. If this is the case, please rebuild the entire solution.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
  3. Andrew
    Andrew avatar
    202 posts
    Registered:
    05 Jun 2009
    20 Aug 2009
    Link to this post
    Hi Georgi.

    That was indeed the problem i recompiled the custom controls.
    And was able to get to the login screen.
    However, now i get this error:

    Server Error in '/via_web' Application. 
    -------------------------------------------------------------------------------- 
     
    No provider with name 'Wiki' has not been set  
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.  
     
    Exception Details: System.Configuration.ConfigurationErrorsException: No provider with name 'Wiki' has not been set 
     
    Source Error:  
     
     
    Line 267:            foreach (IWebModule module in ModuleManager.GetWebModulesValues()) 
    Line 268:            { 
    Line 269:                if (module is SecuredModule && ((SecuredModule)module).CanCreate()) 
    Line 270:                    webModules.Add(module); 
    Line 271:            } 
      
     

  4. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    20 Aug 2009
    Link to this post
    Hi Andrew,

    Could you please check that you included all the sections for the Wiki module in the web.config file? Since the Wiki module is new to the system, it should be properly registered in the web.config file.

    All the best,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
    Answered
  5. Andrew
    Andrew avatar
    202 posts
    Registered:
    05 Jun 2009
    21 Aug 2009
    Link to this post
    Yes, it appears that was the problem i used a file comparison tool. But somehow missed a few lines.
    Having now checked the details manually i corrected the problem.

    Thanks for your help.
  6. Georgi
    Georgi avatar
    3583 posts
    Registered:
    28 Oct 2016
    21 Aug 2009
    Link to this post
    Hi Andrew,

    I am glad that you have the 3.7 version running fine now.
    Let me know if you have any other questions!

    Regards,
    Georgi
    the Telerik team

    Instantly find answers to your questions on the newTelerik Support Portal.
    Check out the tipsfor optimizing your support resource searches.
Register for webinar
6 posts, 1 answered