+1-888-365-2779
Try Now
More in this section

Forums / Set-up & Installation / Works on Development, but not host

Works on Development, but not host

4 posts, 0 answered
  1. Randy Bauer
    Randy Bauer avatar
    67 posts
    Registered:
    25 Sep 2009
    18 Nov 2009
    Link to this post
    Hello,

    I have my site working on my development machine and on a seperate development web server.  I just move the files from my development machine to the development webserver, setup IIS, and it worked.  I am getting the following error when I move the site up to the hosting site.  I do not have control over IIS there and I'm not sure what the issue might be.  Here is the error I am getting:

    The type or namespace name 'RisingTide' could not be found (are you missing a using directive or an assembly reference?)

    Any suggestions would be greatly appreciated,

    -R
  2. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    18 Nov 2009
    Link to this post
    Hello Randy Bauer,

    The error is not thrown from Sitefinity code. the error says that youhave some classes which uses RisingTide namespace and it cannot be found. Check whether you have migrated all files and you have reference to all required dlls.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Randy Bauer
    Randy Bauer avatar
    67 posts
    Registered:
    25 Sep 2009
    18 Nov 2009
    Link to this post
    Rising Tide is the name of the master page.  I copied everything in the folder.  Is there a way to check to see what my local version is referencing.

    I just copied everything to another development web server and setup the virtual directory and everything worked.  I'm contacting the host provider to see if they can review the IIS settings, but I'm not sure that will help me.

    Thanks,

    -R
  4. Ivan Dimitrov
    Ivan Dimitrov avatar
    16072 posts
    Registered:
    09 Dec 2016
    19 Nov 2009
    Link to this post
    Hello Randy Bauer,

    The namespaces element defines a collection of import directives to use during assembly pre-compilation. This attribute corresponds to the @ Import directive on an ASP.NET page. So you are referencing a non existing or not accessible namespace and as a result the error you see is thrown. Again make sure that you have reference to this namespace. You can cright click on your project in VS and select Property Pages.

    Regards,
    Ivan Dimitrov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Register for webinar
4 posts, 0 answered