I'm not sure about you guys, but I really hate code like this:
item.Parent = sf.DocumentLibraries().Where(l => l.Title ==
item.Title = title; item.UrlName = title +
There are all sorts of drawbacks to this sort of code. Not the least of which is that it's not clear when you've made all the necessary calls and in what order. There's no intellisense support when you get down into the later code bits, and it's just verbose() with() lots() of() unnecessary() parenthesis()
It's like writing in nothing but run-on sentences and expecting your teacher to give a good grade because its short and dense and efficient and maybe you think it looks nicer but it's a lot harder to read because there's no separation of thought.