+1-888-365-2779
Try Now
More in this section

Forums / Thunder / Designers in 5.4

Designers in 5.4

13 posts, 0 answered
  1. Steve
    Steve avatar
    3037 posts
    Registered:
    03 Dec 2008
    22 Feb 2013
    Link to this post

    The resource links in a new designer (generated by thunder) look like this

    <sitefinity:ResourceLinks ID="resourcesLinks" runat="server">
        <sitefinity:ResourceFile Name="Styles/Ajax.css" />
        <sitefinity:ResourceFile Name="Styles/jQuery/jquery.ui.core.css" />
        <sitefinity:ResourceFile Name="Styles/jQuery/jquery.ui.dialog.css" />
        <sitefinity:ResourceFile Name="Styles/jQuery/jquery.ui.theme.sitefinity.css" />
    </sitefinity:ResourceLinks>

     Now I'm getting a ton of error log errors looking for these files, usually under the themes folder...related?  Are these relative or pulled from from the resources assembly?

  2. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    22 Feb 2013 in reply to Steve
    Link to this post

    Hey Steve,

    Actually this problem exists in Sitefinity, thunder just inherits the bug. If you go to backend page edit the files 404 as well. (turn stylesheet combining off for a minute and you'll see it)

    Had a support ticket open this week and quote
    "You are correct. I have been testing it more and the files that are 404ing are found in the Telerik.Sitefinity.Resources by default. I will pass this along to the QAs so they can investigate it further and log it as a bug."

    So for the time being, they won't be pulled from the resources but we need to manually include them in the styles folder.

    Jochem

  3. Stacey
    Stacey avatar
    291 posts
    Registered:
    18 Oct 2012
    26 Feb 2013
    Link to this post

    I was not able to find these in the SDK anywhere.  Did you extract them with JustDecompile?

    Edit:  That went faster than I thought.  I went ahead and extracted them for now and that does take care of the 404's.

    Glad I found this post, I was about to pull my hair out trying to determine what I changed in my template....which was nothing ;P

     

  4. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    26 Feb 2013
    Link to this post
    Hi,

     You can also load them from the Telerik.Sitefinity.Resources.dll

    <sf:ResourceFile Name="Telerik.Sitefinity.Resources.Themes.Default.Styles.jQuery.jquery.ui.core.css"  Static="True"/>
      
        <sf:ResourceFile Name="Telerik.Sitefinity.Resources.Themes.Default.Styles.jQuery.jquery.ui.dialog.css" Static="True"/>
      
        <sf:ResourceFile Name="Telerik.Sitefinity.Resources.Themes.Default.Styles.jQuery.jquery.ui.theme.sitefinity.css"  Static="True"/>

    We have identified and resolved the issue causing this problem in the backend.

    Greetings,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Jochem Bökkers
    Jochem Bökkers avatar
    787 posts
    Registered:
    13 Aug 2007
    26 Feb 2013 in reply to Atanas Valchev
    Link to this post

    @Atanas,

    What about ajax.css? 
    It's not a 404 on any of the default widget/page editing, but Steve's right that it gets included when creating a new designer. Should it be Telerik.Sitefinity.Resources.Themes.Default.Styles.Ajax.css?

    Jochem

  6. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    01 Mar 2013
    Link to this post
    Hello,

    Yes, this is the path to the file. 

    Kind regards,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Randy
    Randy avatar
    7 posts
    Registered:
    07 Nov 2012
    01 Mar 2013
    Link to this post

    We are getting the same errors in our error logs after upgrading to 5.4.  Is there a fix or do we have to add the code posted by Atanas?

     

    If so, where do you add that code?

     

    Thanks

  8. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    06 Mar 2013
    Link to this post
    Hi,

    If you are getting the error from your theme, you can add the attached files to the appropriate folder and it will resolve the error. 

    All the best,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  9. gregory hernandez
    gregory hernandez avatar
    59 posts
    Registered:
    10 Jul 2009
    22 Apr 2013 in reply to Atanas Valchev
    Link to this post
    Hi All,

    Atanas, so how exactly does one load them from the Telerik.Sitefinity.Resources.dll?
    Where do we place the sample code you provided here?

    (Attach: screenshot of the "files not found" in Chrome's Console.)

    Thanks,
    Gregory
  10. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    25 Apr 2013
    Link to this post
    Hello,

    The provided code can be used on the master page.

    Greetings,
    Atanas Valchev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Ricky White
    Ricky White avatar
    3 posts
    Registered:
    21 Jun 2012
    08 Jan 2014 in reply to Atanas Valchev
    Link to this post
    Atanas, we are upgrading a client that is on 5.2 and we need to go to 5.4 first.  After upgrading, we are getting this:

    ResourceName property of the ResourceLinks has specified a resource with an invalid extension. Allowed extensions are: .css, .jpg, .jpeg, .gif, .png and .js

    Is this the same issue and if so, where can I get the code to drop in the template?  I didn't see it attached.
  12. woodie
    woodie avatar
    3 posts
    Registered:
    07 Mar 2011
    10 Jan 2014
    Link to this post
    having this exact issue myself.  has there been a resolution?
  13. Atanas Valchev
    Atanas Valchev avatar
    414 posts
    Registered:
    04 Jan 2016
    13 Jan 2014
    Link to this post
    Hi,

    I am attaching the archive again. If you are upgrading, please, upgrade to the latest version where the issue is no longer present.

    Regards,
    Atanas Valchev
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
13 posts, 0 answered