+1-888-365-2779
Try Now
More in this section

Forums / Thunder / Updates Not Persisting from Thunder

Updates Not Persisting from Thunder

5 posts, 0 answered
  1. Jaime
    Jaime avatar
    5 posts
    Registered:
    23 Mar 2013
    22 Sep 2013
    Link to this post
    Make sure the debug environment server has to be same server as the Thunder .
    http://localhost:<somport>  - if you are using internal visual studio development server. http://<somelocalurl>  - if you are using IIS. 
    Changes weren't updating so it was really annoying. I thought there were some caching issues.

    Turn off caching during development

    Turn off output cashing in Administration/Settings/Advanced/System/Output...Caching.
     
  2. Miroslava
    Miroslava avatar
    57 posts
    Registered:
    22 Feb 2016
    23 Sep 2013
    Link to this post
    Hello Jaime,

    Thank you for using Thunder!

    Would you please give us more detailed steps to reproduce the problem? It would be great if you can record a short video and send it to us, so we can investigate this issue. 

    Regards,
    Miroslava
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Jaime
    Jaime avatar
    5 posts
    Registered:
    23 Mar 2013
    23 Sep 2013 in reply to Miroslava
    Link to this post
    I figured it out if you read the post carefully. But, if you want to reproduce it follow the steps below. 

    1. Within project properties set Use Visual Studio Development Server 
    2. Set custom host file name ex spwebsite                        127.0.0.1
    3. Connect to Sitefinity Thunder via http://spwebsite
    4. Update a Widget Template from within Visual Studio (changes aren't reflected). 

    The problem seems to be that when the servers are different the updates don't persist.

  4. Roberto Modica
    Roberto Modica avatar
    146 posts
    Registered:
    08 Feb 2008
    19 Dec 2013
    Link to this post
    This is happening to me aswell.  The development application and iis website are on the same box (database is on a different box) and widget templates specifically are flakey (everything else persists).

     - Open a widget template (using thunder in VS2010/12/13)
    - Edit it
    - Save it
    - Close it
    - Changes are not persisted and the old version is still there
  5. Ivan D. Dimitrov
    Ivan D. Dimitrov avatar
    310 posts
    Registered:
    26 Mar 2015
    23 Dec 2013
    Link to this post
    Hi Jaime,

    I just tested the behavior you are describing and failed to reproduce it. Please view this video for further clarification. I would suggest you open a support ticket and seek further resolution from our support team.

    Regards,
    Ivan D. Dimitrov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
5 posts, 0 answered