More in this section
Forums / Bugs & Issues / 8.1 to 9.2 Upgrade - Dynamic Modules Issue

8.1 to 9.2 Upgrade - Dynamic Modules Issue

The forums are in read-only mode. In case that you want to directly contact the Progress Sitefinity team use the support center. In our Google Plus group you can find more than one thousand Sitefinity developers discussing different topics. For the Stack Overflow threads don’t forget to use the “Sitefinity” tag.
3 posts, 0 answered
  1. Joseph
    Joseph avatar
    0 posts
    Registered:
    18 Apr 2016
    15 Feb 2017
    Link to this post

    Hello all,

    I'm trying to upgrade a solution from 8.1 to 9.2 which uses several dynamic types.

    After the upgrade I can no longer edit any of the existing dynamic types all the editing screen display something similar to "Missing TypeIDControl" and do not allow edits.

    I know that Sitefinity had changes related to dynamic types going from 8.1 to 9. Is there something additional that needs to be done for these backend pages to work after the upgrade?

  2. Victor Leontyev
    Victor Leontyev avatar
    65 posts
    Registered:
    01 Jul 2014
    16 Feb 2017 in reply to Joseph
    Link to this post

    Sounds like something wrong with configuration files.

    May be you overwrote by mistake some configuration files during upgrade?

  3. Joseph
    Joseph avatar
    0 posts
    Registered:
    18 Apr 2016
    21 Feb 2017
    Link to this post

    That's the interesting thing though, before the upgrade their's one large DynamicModulesConfig and afterwards there are a bunch of smaller ones (I know that was a change in 9.0, i think).

    But it seems like the old content types aren't respecting the new configurations.

    Does something need to be changed in settings to make those dynamic types use the new configs? I would of thought the upgrade would handle that though.

3 posts, 0 answered