More in this section

Forums / Bugs & Issues / Beta Migration Tool - Connection Successful, but not the Migration

Beta Migration Tool - Connection Successful, but not the Migration

2 posts, 0 answered
  1. Chris
    Chris avatar
    49 posts
    Registered:
    20 Jul 2010
    25 Oct 2011
    Link to this post
    I have a sitefinity 3.7 SP4 website that I am trying to migrate to sitefinity 4.2 using the built in Migration tool.
    I've followed the instructions to manually configure my old 3.7 site in preperation for the migration.
    Both the 3.7 site and the 4.2 site are hosted on the same machine. the 3.7 site uses IIS and has a local IP address that I use to connect to it.
    The 4.2 site uses the sitefinity project manager for now, but I will eventually configure it to run under IIS.
    I'm using a machine running windows 2003, IIS6.

    In the sitefinity 4.2 migration tool I enter the IP address of my 3.7 site like so : http://192.168.0.2:8080
    clicking Test Connection returns "Connection has been successfully established"
    Good

    I check off the items I wish to migrate.
    Click "Check items count" which returns "Connection to 3.7 project has failed. Items counts haven't been calculated"
    Uh, not good...
    Try migration anyway, Clicking ' Begin Migration'
    A green bar appears that says "Migration process is completed. For details view the log file"
    Oh cool! Oh wait no it lied... it goes on to say...
    "Error: Could not find http:\/\/192.168.0.2:8080\/MigrationService.svc on the source site. Error details:The requested service, 'http:\/\/192.168.0.2:8080\/MigrationService.svc' could not be activated. See the server's diagnostic trace logs for more information.
    Migration stopped.
    "

    All those "\/\/" aren't anything I entered, I wonder if your attempt at 1337 speak is why you cant find the migration service, mr. migration tool. Because I assure you that file is there.

    So the tool first tried to lie to me and then told me how it failed. 

    What do?
  2. Pavel Iliev
    Pavel Iliev avatar
    140 posts
    Registered:
    18 Jul 2016
    26 Oct 2011
    Link to this post
    Hi Chris,

    In order to check if the service is there you can test in in your browser - http://192.168.0.2:8080/MigrationService.svc?wsdl

    I'd suggest to use the latest internal build, there are many improvements and also the Project Manager can be used to setup the 3.7 site automatically and then run the 4.2 migration under IIS.

    You can also check the log files for 4.2 that are located in app_data\sitefinity\logs (error.log & migration.log) and the log for 3.7 - app_data\sitefinity.log.

    Kind regards,
    Pavel Iliev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
2 posts, 0 answered